no visual feedback for sending unsent messages

VERIFIED DUPLICATE of bug 81625

Status

VERIFIED DUPLICATE of bug 81625
17 years ago
10 years ago

People

(Reporter: blizzard, Assigned: bugzilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Right now there's no way to tell that unsent messages are being processed. 
After you start sending unsent messages they start silently vanishing out of the
Unsent Messages folder but there's nothing to let the user know that their menu
selection succeeded.

Comment 1

17 years ago
reassigning to JF - probably a dup, and this is because msg send doesn't send
status to msg windows, if I understand correctly. Cc'ing mscott since he knows a
lot about this code too.
Assignee: bienvenu → ducarroz
Component: Offline → Composition

Comment 2

17 years ago
Chris.
The only visual feedback currently is at the bottom frame
of messenger (just to the right of the browser,mail,composer icons)
Where once you send an unsent message, it displays on the
bottom frame: "Sending Unsent Messages".

But maybe a bigger/more visual display is in order.
(Reporter)

Comment 3

17 years ago
Yeah, I didn't think that was enough since it didn't give any feedback like
"sending x of x messages" or a completion bar or anything.  It confuses even me
and I tolerate some poor UIs. :)  jglick is also cc'ed on this bug in hopes that
she might have some UI ideas or even plans for this already.

Comment 4

17 years ago
This is quite a major problem if you're sending a load of messages with 
attachments. Sending the messages takes a long time but there's very little 
visual feedback to indicate that the messages are being sent. This results in 
the user either:

a) thinking that the messages aren't being sent and switching to Outlook 
Express.

b) thinking that the messages have finished sending and disconnecting from the 
Internet. When they find out that they hadn't finished sending, they go and use 
Outlook Express.

Niether of these solutions are particularly desireable.

I did wonder if maybe there was no dialogue so that the user can do other 
things while Mail (or Mail and Newsgroups, or whatever it's called now) is 
sending messages in the background. However, I'm scared to touch it while the 
sending operation is in progress and I expect most other users feel the same.

Updated

17 years ago
Keywords: nsbeta1

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 81625 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
I get to dupe one developer bug :) 
Verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.