Large app icons are 284px, not 289px

RESOLVED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: squib, Assigned: squib)

Tracking

unspecified
2.0 S5 (4july)
x86_64
Linux
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(b2g-v2.0 fixed, b2g-v2.1 fixed)

Details

(Whiteboard: interaction-design)

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
kgrandon
: review+
Details | Review | Splinter Review
(Assignee)

Description

4 years ago
For some reason, the largest app icons are all labeled as being 289px in their filenames and in the manifests. They are, in fact, 284px. We should probably fix this.

References:

apps/sms/manifest.webapp
45:    "289": "/style/icons/sms_289.png"

apps/wallpaper/manifest.webapp
47:    "289": "/style/icons/wallpaper_289.png"

apps/costcontrol/manifest.webapp
50:  "289": "/style/icons/costcontrol_289.png"

apps/music/manifest.webapp
61:    "289": "/style/icons/music_289.png"

apps/communications/manifest.webapp
19:        "289": "/dialer/style/icons/dialer_289.png"
48:        "289": "/contacts/style/icons/contacts_289.png"

apps/clock/manifest.webapp
41:    "289": "/style/icons/clock_289.png"

apps/browser/manifest.webapp
48:    "289": "/shared/resources/branding/browser_289.png"

apps/video/manifest.webapp
44:    "289": "/style/icons/video_289.png"

apps/calendar/manifest.webapp
47:    "289": "/style/icons/calendar_289.png"

apps/callscreen/manifest.webapp
36:    "289": "/style/icons/dialer_289.png"

apps/email/manifest.webapp
48:    "289": "/style/icons/email_289.png"

apps/fm/manifest.webapp
40:    "289": "/style/icons/fm_289.png"

apps/gallery/manifest.webapp
68:    "289": "/style/icons/gallery_289.png"

apps/settings/manifest.webapp
82:    "289": "/style/icons/settings_289.png"

apps/camera/manifest.webapp
61:    "289": "/style/icons/camera_289.png"
Is this something you can help with? This was filed because of comment#20 in Bug 1020588
Flags: needinfo?(pivanov)
Whiteboard: interaction-design
(Assignee)

Comment 2

4 years ago
Taking this since it's easy to automate.
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
Flags: needinfo?(pivanov)
(Assignee)

Comment 3

4 years ago
Created attachment 8444935 [details] [review]
Fix it
(Assignee)

Comment 4

4 years ago
Comment on attachment 8444935 [details] [review]
Fix it

Yuren, do you think you could look at this? It's sort of build system related...

I did everything via some shell commands, which are listed in the PR.
Attachment #8444935 - Flags: review?(yurenju.mozilla)
(Assignee)

Comment 5

4 years ago
Comment on attachment 8444935 [details] [review]
Fix it

Switching r? to Kevin Grandon...
Attachment #8444935 - Flags: review?(yurenju.mozilla) → review?(kgrandon)
Comment on attachment 8444935 [details] [review]
Fix it

Seems to work for me, thanks!
Attachment #8444935 - Flags: review?(kgrandon) → review+
(Assignee)

Comment 7

4 years ago
Landed: https://github.com/mozilla-b2g/gaia/commit/6bd60af83260095768e703233b9bac8239d22db3
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
(Assignee)

Comment 8

4 years ago
Comment on attachment 8444935 [details] [review]
Fix it

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1014591
[User impact] if declined: Not sure; icons might be slightly off in scale?
[Testing completed]: Manually tested with all apps
[Risk to taking this patch] (and alternatives if risky): Low risk, just moves some files around (and I did this via a script to avoid any typos)
[String changes made]: None
Attachment #8444935 - Flags: approval-gaia-v2.0?
Thanks guys :)

Updated

4 years ago
Attachment #8444935 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+
v2.0: https://github.com/mozilla-b2g/gaia/commit/8ef9bba63381da2dad36ac5a1468f81f4f2ce8ff
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
Target Milestone: --- → 2.0 S5 (4july)
You need to log in before you can comment on or make changes to this bug.