Closed Bug 1029255 Opened 8 years ago Closed 8 years ago

Crash: Long press on Android 2.2/2.3 text selection action bar crashes

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
critical

Tracking

(firefox32 affected, firefox33 affected)

RESOLVED DUPLICATE of bug 1014181
Tracking Status
firefox32 --- affected
firefox33 --- affected

People

(Reporter: liuche, Unassigned)

References

Details

(Keywords: crash)

Crash Data

06-23 17:05:09.393: E/GeckoAppShell(2378): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 1 ("main")
06-23 17:05:09.393: E/GeckoAppShell(2378): java.lang.NoSuchMethodError: android.view.MenuItem.getActionView
06-23 17:05:09.393: E/GeckoAppShell(2378): 	at org.mozilla.gecko.ActionModeCompat.onMenuItemLongClick(ActionModeCompat.java:102)
06-23 17:05:09.393: E/GeckoAppShell(2378): 	at org.mozilla.gecko.widget.GeckoPopupMenu.onMenuItemLongClick(GeckoPopupMenu.java:161)
06-23 17:05:09.393: E/GeckoAppShell(2378): 	at org.mozilla.gecko.menu.GeckoMenu.access$100(GeckoMenu.java:35)
06-23 17:05:09.393: E/GeckoAppShell(2378): 	at org.mozilla.gecko.menu.GeckoMenu$2.onLongClick(GeckoMenu.java:230)
06-23 17:05:09.393: E/GeckoAppShell(2378): 	at android.view.View.performLongClick(View.java:2427)
06-23 17:05:09.393: E/GeckoAppShell(2378): 	at android.view.View$CheckForLongPress.run(View.java:8794)
06-23 17:05:09.393: E/GeckoAppShell(2378): 	at android.os.Handler.handleCallback(Handler.java:587)
06-23 17:05:09.393: E/GeckoAppShell(2378): 	at android.os.Handler.dispatchMessage(Handler.java:92)
06-23 17:05:09.393: E/GeckoAppShell(2378): 	at android.os.Looper.loop(Looper.java:143)
06-23 17:05:09.393: E/GeckoAppShell(2378): 	at android.app.ActivityThread.main(ActivityThread.java:4701)
06-23 17:05:09.393: E/GeckoAppShell(2378): 	at java.lang.reflect.Method.invokeNative(Native Method)
06-23 17:05:09.393: E/GeckoAppShell(2378): 	at java.lang.reflect.Method.invoke(Method.java:521)
06-23 17:05:09.393: E/GeckoAppShell(2378): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:868)
06-23 17:05:09.393: E/GeckoAppShell(2378): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:626)
06-23 17:05:09.393: E/GeckoAppShell(2378): 	at dalvik.system.NativeStart.main(Native Method)
06-23 17:05:09.393: E/Gecko(2378): mozalloc_abort: Redirecting call to abort() to mozalloc_abort

This looks like we are trying to use a method that might not be included in the compat library for older phones. Adding Wes as a mentor because he mentored the original bug.
Component: General → Text Selection
Depends on: 943908
This bug requires two main things:

- Use MenuItemCompat.getActionView(MenuItem) instead of menuItem.getActionView() in ActionModeCompat.showTooltip()

- Add android.support.v7 so we can use the ActionBarActivity subclass of FragmentActivity

http://stackoverflow.com/questions/18832890/android-nullpointerexception-on-searchview-in-action-bar/18942838#18942838
Component: Text Selection → General
Mentor: wjohnston
Duplicate of this bug: 1029623
Severity: normal → critical
Crash Signature: [@ java.lang.NoSuchMethodError: android.view.MenuItem.getActionView at org.mozilla.gecko.ActionModeCompat.onMenuItemLongClick(ActionModeCompat.java)]
Keywords: crash
Summary: Crash: Long press on Android 2.2 text selection action bar crashes → Crash: Long press on Android 2.2/2.3 text selection action bar crashes
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1014181
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.