If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Intermittent test_homescreen_move_app.py test_homescreen_move_app.TestMoveApp.test_move_app_position | IndexError: list index out of range

RESOLVED DUPLICATE of bug 1033346

Status

Firefox OS
Gaia::UI Tests
RESOLVED DUPLICATE of bug 1033346
3 years ago
3 years ago

People

(Reporter: KWierso, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=42281942&tree=Fx-Team
b2g_ubuntu64_vm fx-team opt test gaia-ui-test on 2014-06-23 10:03:31 PDT for push e2ddcb912e08

slave: tst-linux64-spot-260



10:37:08     INFO -  TEST-START test_homescreen_move_app.py
10:37:08     INFO -  test_move_app_position (test_homescreen_move_app.TestMoveApp)
10:37:23     INFO -  Verify the user can move an application around on the homescreen. ... ERROR
10:37:23     INFO -  ======================================================================
10:37:23     INFO -  ERROR: None
10:37:23     INFO -  ----------------------------------------------------------------------
10:37:23     INFO -  Traceback (most recent call last):
10:37:23     INFO -    File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette/marionette_test.py", line 170, in run
10:37:23     INFO -      testMethod()
10:37:23     INFO -    File "/builds/slave/test/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/homescreen/test_homescreen_move_app.py", line 23, in test_move_app_position
10:37:23     INFO -      first_app_before_move = self.homescreen.visible_apps[0].name
10:37:23    ERROR -  TEST-UNEXPECTED-FAIL | test_homescreen_move_app.py test_homescreen_move_app.TestMoveApp.test_move_app_position | IndexError: list index out of range
10:37:23     INFO -  ----------------------------------------------------------------------
10:37:23     INFO -  Ran 1 test in 15.340s
10:37:23  WARNING -  FAILED (errors=1)
(Reporter)

Comment 1

3 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=42308590&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=42299819&tree=Mozilla-Inbound
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

3 years ago
Component: Gaia::Homescreen → Gaia::UI Tests
I submitted a PR with a fix for this in bug 1033346.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1033346
You need to log in before you can comment on or make changes to this bug.