when a connection is halted by a switch from wifi to mobile data (or vice versa), further connections can't be established

RESOLVED DUPLICATE of bug 1024614

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 1024614
4 years ago
2 years ago

People

(Reporter: Mathieu Pellerin, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(fennec32+)

Details

(Reporter)

Description

4 years ago
If Firefox's ongoing connection to a site is halted due to connection type switch (e.g. a WiFi going out of rage making the device switch to mobile data, or vice versa), Firefox is then unable to establish connections to any site. The only way it'll be able to establish connection back is to either revert to the type of connection prior to the switch (i.e. getting back within range of the lost WiFi), or kill Firefox and reload it.

This has been affecting my usage of Firefox Nightly for the last 3-4 weeks. 

My device is a Samsung Galaxy Note 2 running Android version 4.4.2.

Updated

4 years ago
tracking-fennec: --- → ?
Do you have an example page showcasing this? I tried to reproduce this using http://etherpad.mozilla.org and was unsuccessful. I loaded the page on WiFi, I then walked out of range and transitioned to mobile-data (in my case, LTE) and was able to continue using the site and load other pages fine.

> This has been affecting my usage of Firefox Nightly for the last 3-4 weeks. 

This would imply that it's a recent regression. Are you able to consistently reproduce where you could help narrow down what introduced the issue? We have past Nightly APK builds up on http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/ in the 'mozilla-central-android' branded folders
(Reporter)

Comment 2

4 years ago
Aaron, the transition to/from mobile-data needs to occur as the browser is in a transaction (i.e. loading a webpage). From what I can observe, if there are no open connections, the transition will not paralyze the browser. So to real test would be to walk out of range at etherpad.mozilla.org is loading.

I'll try and come up with easy steps to reproduce, that might do a better job than the above description.
Bug 1024614 may remedy this among many other mobile network issues; CC'ing snorp
Yes this is a dupe of 1024614.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1024614
tracking-fennec: ? → 32+
You need to log in before you can comment on or make changes to this bug.