crashes on redirect Trunk [@nsHttpChannel::ProcessResponse]

VERIFIED FIXED in mozilla0.9.5

Status

()

Core
Networking: HTTP
P1
critical
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: dbaron, Assigned: Darin Fisher)

Tracking

({crash, topcrash})

Trunk
mozilla0.9.5
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: want for 0.9.5, crash signature)

Attachments

(1 attachment)

Crashes at nsHttpChannel::ProcessResponse started with build 2001-10-01-21 and
continued in build 2001-10-02-06.  A number of user comments mention redirects.

 nsHttpChannel::ProcessResponse	[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpChannel.cpp  line 486]
	 nsHttpChannel::OnStartRequest
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpChannel.cpp  line 2266]
	 nsOnStartRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp  line 126]
	 PL_HandleEvent
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 591]
	 PL_ProcessPendingEvents
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 524]
	 _md_EventReceiverProc
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 1072]
	 nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp  line 457]
	 main1
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1307]
	 main
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1624]
	 WinMain
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1642]
	 WinMainCRTStartup()
	 KERNEL32.DLL + 0x17d08 (0x77e97d08)
Summary: crashes on redirect [@nsHttpChannel::ProcessResponse] → crashes on redirect [@nsHttpChannel::ProcessResponse]
Related to the fix for bug 94004?
Talkback shows the crash is because mCacheEntry is null on line 485. 
(GetTransport should be at offset 0x38 in the vtable.):

6084aec1 8b08             mov     ecx,[eax]              <=== CRASH HERE, eax=0
6084aec3 ff5138           call    dword ptr [ecx+0x38]
6084aec6 8bd8             mov     ebx,eax
6084aec8 f7c300000080     test    ebx,0x80000000
6084aece 7522             jnz     6084aef2

Whiteboard: want for 0.9.5
Severity: normal → critical
Keywords: crash, topcrash

Comment 3

17 years ago
darin
Assignee: neeti → darin
(Assignee)

Comment 4

17 years ago
i c the problem.. patch-in-hand
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla0.9.5
(Assignee)

Comment 5

17 years ago
Created attachment 51907 [details] [diff] [review]
v1.0 should fix the problem
(Assignee)

Comment 6

17 years ago
this crash corresponds to a cacheable redirect sent with 'cache-control: no-store'

the patch simply adds a null check for mCacheEntry... when working on bug 94004,
i forgot that InitCacheEntry could succeed without there actually being a cache
entry.

Comment 7

17 years ago
Comment on attachment 51907 [details] [diff] [review]
v1.0 should fix the problem

r=gagan
Attachment #51907 - Flags: review+

Comment 8

17 years ago
Comment on attachment 51907 [details] [diff] [review]
v1.0 should fix the problem

sr=mscott
Attachment #51907 - Flags: superreview+

Updated

17 years ago
Summary: crashes on redirect [@nsHttpChannel::ProcessResponse] → crashes on redirect Trunk [@nsHttpChannel::ProcessResponse]
Comment on attachment 51907 [details] [diff] [review]
v1.0 should fix the problem

a=dbaron
Attachment #51907 - Flags: approval+
(Assignee)

Comment 10

17 years ago
fixed-on-trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 11

17 years ago
*** Bug 103026 has been marked as a duplicate of this bug. ***
*** Bug 103105 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 13

17 years ago
*** Bug 103075 has been marked as a duplicate of this bug. ***
*** Bug 103191 has been marked as a duplicate of this bug. ***
*** Bug 103100 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
*** Bug 103131 has been marked as a duplicate of this bug. ***
*** Bug 103525 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
verified - not showing up in talkback anymore
Status: RESOLVED → VERIFIED
*** Bug 110654 has been marked as a duplicate of this bug. ***
Crash Signature: [@nsHttpChannel::ProcessResponse]
You need to log in before you can comment on or make changes to this bug.