If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

YouTube playing sudden turns loading video, while audio still plays (Both FF28 and FF30)

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
P3
normal
RESOLVED WORKSFORME
3 years ago
a year ago

People

(Reporter: daniel.2345, Unassigned)

Tracking

({html5})

30 Branch
x86_64
Windows 7
html5
Points:
---

Firefox Tracking Flags

(platform-rel ?)

Details

(Whiteboard: [platform-rel-Youtube])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; Trident/7.0; Touch; .NET4.0E; .NET4.0C; Tablet PC 2.0; InfoPath.3; rv:11.0) like Gecko

Steps to reproduce:

1. Have Firefox 28 or 30.
2. Go to YouTube and play a long HTML5 video in HQ with average internet speed.
3. Wait until video stops to "load" but audio continues playing(happens now and then).
==achieved part1, part2 below==
4. Close the tab or load another page.



Actual results:

The video stops to "load" but audio continued to play, regardless of current tab closing or address changed, the audio will continue to play until you close Firefox. 

*Unless* you change the video time in the time seeker within the HTML5 video player to stop audio playing then reload either the HTML5 player or the page to reload your video to play it normally.

Also, pause and unpause does nothing.


Expected results:

Video playing smoothly when stream is fine, or pause when stream needed to load, and allow user to pause and unpause both video and audio at the same time.
(Reporter)

Updated

3 years ago
Keywords: html5
(Reporter)

Updated

3 years ago
OS: Windows 8.1 → Windows 7
Hardware: x86 → x86_64

Comment 1

3 years ago
Reproducing in Aurora 32.0a2 (2014-06-22) on Win7 with the youtube HTML5 player enabled. Seen it twice today.

Once the video gets into this state nothing will recover it other than a tab reload.

Comment 2

3 years ago
This also occurs with regular mp4-container video if I load it directly as a URL and click 'play' on the built-in player. So this isn't youtube specific, it merely affects HTML5 youtube along with other uses of HTML5 video.
Component: Untriaged → Video/Audio
Product: Firefox → Core
Component: Audio/Video → Audio/Video: Playback
Is this issue still reproducible?
Flags: needinfo?(daniel.2345)
(Reporter)

Comment 4

2 years ago
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #3)
> Is this issue still reproducible?

Unfortunately yes, but very unlikely. I suspect this is formed by several different bugs? It is unlikely to write a way to reproduce the bug.

I'm using FF44 Nightly
Flags: needinfo?(daniel.2345)
Priority: -- → P2
platform-rel: --- → ?
Whiteboard: [platform-rel-Youtube]
(Reporter)

Comment 5

a year ago
Just saw this bug notification in my email. I have to say this problem no longer occurs to me. So if anyone else can't reproduce this bug, they can safely change to status to resolved.
Mass change P2 -> P3
Priority: P2 → P3
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.