Ubuntu menu bar and dock are not always hidden in fullscreen mode

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: petruta, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8445110 [details]
Black line visible where the top bar should be

Reproducible on:
Firefox 31 beta 4 - 20140623175014
Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0
latest Aurora 32.0a2 - 20140623004002
Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
latest Nightly 33.0a1 - 20140623030201
Mozilla/5.0 (X11; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
 
Steps to reproduce:
1. Open several pages in different tabs
(https://www.mozilla.org/en-US/firefox/31.0/firstrun/ , about:newtab , 
2. Open each of them in fullscreen mode (F11)

Actual results:
In some cases the dock and top bar disappear in full screen leaving a black line at the top. This is not the case for all pages.

Expected results:
Entering full screen mode should either hide Ubuntu bars without artifacts either leave them on. 

Notes: 1. The issue is not a regression, it reproduces back to Firefox 4.0.1. 
2. It doesn't reproduce on Win 7 or Mac OSX
3. I could see the black line on Ubuntu 13.04 64-bit, but not on the Ubuntu 13.04 32-bit same machine or Ubuntu 13.04 64-bit another machine.
(Reporter)

Comment 1

4 years ago
Created attachment 8445113 [details]
Dock and top bar visible in fullscreen
Does this still happen if you remove the add-ons Ubuntu installs by default?
(Reporter)

Comment 3

4 years ago
Yes, I could still see the black line with all plugins & add-ons disabled, starting in safe mode or after reseting Firefox.
(In reply to Petruta Rasa [QA] [:petruta] from comment #3)
> Yes, I could still see the black line with all plugins & add-ons disabled,
> starting in safe mode or after reseting Firefox.

Does this reproduce if you switch to Gnome Shell or XFCE?
(Reporter)

Comment 5

4 years ago
I couldn't reproduce it after I installed Gnome Shell and XFCE.

I'm marking it as RWFM, thanks!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
This might be a bug (or feature) in Unity. Maybe you could report it in Launchpad?
You need to log in before you can comment on or make changes to this bug.