Some Web Literacy 'Maker' badges use different icon to competency pages on webmaker.org

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: doug, Assigned: erik)

Tracking

Details

(Whiteboard: [resources][july11])

Attachments

(1 attachment)

(Reporter)

Comment 1

4 years ago
I'm creating the badge detail pages in BadgeKit and noticed that the icon used on some of the Web Literacy 'Maker' badges are different to those on the relevant competency page at webmaker.org. Not sure if it's because the wiki page hasn't been updated with the latest version of each badge?

----

There are three competencies affected:

* https://wiki.mozilla.org/images/4/4f/Navigation.png / https://webmaker.org/resources/literacy/weblit-Navigation

* https://wiki.mozilla.org/images/6/69/Webmechanics2.png / https://webmaker.org/resources/literacy/weblit-WebMechanics

* https://wiki.mozilla.org/images/5/5d/Infrastructure2.png / https://webmaker.org/resources/literacy/weblit-Infrastructure

----

Also, 'Community Participation' doesn't seem to currently have *any* icon at webmaker.org? 

https://webmaker.org/resources/literacy/weblit-Community
(Reporter)

Updated

4 years ago
Blocks: 1030254
* Doug: which of the /resource pages are currently displaying the wrong icon?

* Can you provide the links, plus the correct icon to use instead?
Flags: needinfo?(doug)
Summary: Some Web Literacy 'Maker' badges use different icon to competency pages on webmaker.org → Wrong icons are displaying on some resource pages
Whiteboard: [resources][july11]
(Reporter)

Comment 3

4 years ago
Apart from the Community Participation page (which lacks an icon), the resource pages are fine. 

We need to update the Navigation, Web Mechanics, and Infrastructure badges so the glyphs match the icons on the relevant resources page. 

Links in Comment 1. :-)
Flags: needinfo?(doug)
(Reporter)

Updated

4 years ago
Summary: Wrong icons are displaying on some resource pages → Some Web Literacy 'Maker' badges use different icon to competency pages on webmaker.org
(Reporter)

Comment 4

4 years ago
Note: I've restored the original bug name, as (apart from Community page) the problem isn't with the resource pages but with the badges.
* I'm sorry Doug -- I'm just not sure what you need a human to do to solve this. Should be an easy fix once we have clear scope.
Flags: needinfo?(michelle)
Flags: needinfo?(doug)
(Reporter)

Comment 6

4 years ago
Clarification, if needed: https://www.youtube.com/watch?v=Xwzl1MykWU8
Flags: needinfo?(doug)

Comment 7

4 years ago
Transcribing Doug's video (which while illustrative is not helpful when scoping & assigning clear tasks in Bugzilla). 

Navigation: 
* Replace icon on https://webmaker.org/resources/literacy/weblit-Navigation --> with  http://fortawesome.github.io/Font-Awesome/icon/arrows/

Web Mechanics: 
* Replace icon on https://webmaker.org/resources/literacy/weblit-WebMechanics --> with  http://fortawesome.github.io/Font-Awesome/icon/cogs/

Infrastructure:
* Replace icon on https://webmaker.org/resources/literacy/weblit-Infrastructure --> with http://fortawesome.github.io/Font-Awesome/icon/database/


Community Participation:
* Currently missing an icon on https://webmaker.org/resources/literacy/weblit-Community --> use the custom icon in this badge https://wiki.mozilla.org/images/f/fd/Communityparticipation3.png

Copying Jess Klein who made the design and can provide the asset for "community participation"
Flags: needinfo?(michelle) → needinfo?(jess)
We actually need to find a new icon for community participation, using the custom icon is currently a burden on the way we've built /resources since it's templated.
Depends on: 1026239
These need to be edited within badgekit, so assigning to Erik.  Erik, once that blocking bug is resolved, could you do us a solid and modify dem badges?
Assignee: nobody → erik
So I'm confused a bit because it seems like there are conflicting instructions here.  Are we changing the icon on the navigation badge to the icon here? https://webmaker.org/resources/literacy/weblit-Navigation

Or is the other way around, and we're changing the icon on that page to the icon on this badge? https://webmaker.org/badges/navigation-maker
(Reporter)

Comment 11

4 years ago
We need to change the icons on the badges to reflect the icon on the relevant resources page. See comment 7. :-)

Erik will need someone to create the badge image first before he can update.
OK, cool.  I had seen that, just wanted to be sure it was still up to date.

I think I can make the badges myself using Andrew's sweet badge studio (http://studio.andrewhayward.net/), as they seem to be using those templates.
(Reporter)

Comment 14

4 years ago
Purrrfect. Thanks Erik!

Closing this bug and have filed Bug 1034083 r.e. Community Participation icon.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Flags: needinfo?(jess)
You need to log in before you can comment on or make changes to this bug.