White space in username creation causes error, but displays no message.

RESOLVED FIXED

Status

Webmaker
Login
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: justinpotts, Assigned: cade)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
During new account creation, a username with white space does not allow account creation and provides no error message.

Steps to reproduce:
1. Go to webmaker.org
2. Login with new account credentials
3. Type in a username with white space ("John Doe", "Web User")
4. Agree to the terms and conditions
5. Click the account creation button

Expected results:
An error should be displayed alerting the user that a username cannot contain white space.

Actual results:
The window closes upon click account creation button, but account is not created and no error is displayed.
(Assignee)

Comment 1

3 years ago
It looks like client side username validation isn't working as expected for any kind of invalid username.

I can get the error entering usernames with other illegal characters: '_', '&', '^', etc.

Updated

3 years ago
Assignee: nobody → cade
Status: NEW → ASSIGNED
(Assignee)

Comment 2

3 years ago
Created attachment 8445469 [details] [review]
https://github.com/mozilla/webmaker.org/pull/832
Attachment #8445469 - Flags: review?(jon)

Updated

3 years ago
Attachment #8445469 - Flags: review?(jon) → review?(kate)
Comment on attachment 8445469 [details] [review]
https://github.com/mozilla/webmaker.org/pull/832

Ok, looks good
Attachment #8445469 - Flags: review?(kate) → review+

Comment 4

3 years ago
Commit pushed to master at https://github.com/mozilla/webmaker.org

https://github.com/mozilla/webmaker.org/commit/49ffd3c93c38f4cdbf47b6c1bb99fd412e649dcc
Bug 1029565 - check username validity in angular create user form
(Assignee)

Comment 5

3 years ago
Building on staging now.
(Assignee)

Comment 6

3 years ago
pushed to prod

https://jenkins.mofoprod.net/view/PROD/job/PRODPUSH-webmakerorg/109/
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.