[Homescreen] Black screen shown during loading when adding a smart collection

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Homescreen
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: tchung, Assigned: aus)

Tracking

unspecified
2.0 S5 (4july)
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [systemsfe], URL)

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8445263 [details]
logcat

Right now, if you try to add a smart collection and there's a delayed load, the user just sees a black screen.   No throbber, no loading message, just a black screen.   We need some kind of placeholder performance bar or page that gives the user a better performance perception than just a black screen.

See screencast:  http://youtu.be/1i-ECpzBlVE

Also, logcat attached.

Repro
1) install 2.0 aurora on Flame (20140624000201)

Gaia      9d2f7bd16a8dc0c74c97c5a40d2f0731f3dfff4b
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/f118b45daada
BuildID   20140624000201
Version   32.0a2
ro.build.version.incremental=109

2) on homescreen, long tap and click "Add smart collections"
3) when the list appears, pick one category to add (ie. Sports)
4) Verify a black screen appears while the page is loading, with no performance indication or progress bar.

Expected:
- some sort of perceptive loading page to indicate the user to wait , it's loading

ActuaL:
- just a black screen, making it feel weird.
(Reporter)

Comment 1

4 years ago
ni UX team for feedback
Flags: needinfo?(firefoxos-ux-bugzilla)
blocking-b2g: 2.0? → 2.0+

Updated

4 years ago
Blocks: 1015336
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
Whiteboard: [systemsfe]
Assignee: nobody → jlal
Depends on: 1029978
Target Milestone: --- → 2.0 S5 (4july)
Probably won't end up fixing this in the next few hours.
Assignee: jlal → nobody
Target Milestone: 2.0 S5 (4july) → ---

Comment 3

4 years ago
Flagging Rob but my initial response is to say that this should follow the established pattern (spinner).
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(rmacdonald)
No longer depends on: 1029978
Duplicate of this bug: 1029978
Some notes here: https://bugzilla.mozilla.org/show_bug.cgi?id=1028452#c22

I feel that we should re-measure this once we solve the geolocation issue in bug 1028452 - it might just fix this, or make it a lot better.
(Assignee)

Comment 6

4 years ago
Created attachment 8447440 [details] [review]
Pull Request - Show spinner when loading new collections
Assignee: nobody → aus
Status: NEW → ASSIGNED
Attachment #8447440 - Flags: review?(kgrandon)
Comment on attachment 8447440 [details] [review]
Pull Request - Show spinner when loading new collections

I think we can probably do better, but a more comprehensive fix for 2.0 can bring a lot of risk. I think we should land this for now as it least gives the user some progress indicator.

I'm also going to upload a screenshot and ask for ui-review? to see if this is acceptable for 2.0.
Attachment #8447440 - Flags: review?(kgrandon) → review+
Created attachment 8447456 [details]
Spinner during create

Jacqueline - here is a screenshot of the treatment we now apply after selecting a collection to create. It is the same spinner as when you are entering the create collection screen, before we load the list of suggested collections.

We are unfortunately unable to change the text of the dialog at this time due to the string freeze. Do you think this is an acceptable approach for 2.0?
Attachment #8447456 - Flags: ui-review?(jsavory)
Gaia-try seemed to not want to run for some reason, but I am verifying all tests locally and this one is simple so landing: https://github.com/mozilla-b2g/gaia/commit/4eea9b9fb0adac7573a2d7afa5e12cb33d952573
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8447456 [details]
Spinner during create

I think this screen will work fine for 2.0.
Attachment #8447456 - Flags: ui-review?(jsavory) → ui-review+
v2.0: https://github.com/mozilla-b2g/gaia/commit/f9cc46b5006cd356dd647ba3edbc34eb8711d089
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
Target Milestone: --- → 2.0 S5 (4july)
Will defer to Jacqueline as per comment 10. Thanks!
Flags: needinfo?(rmacdonald)

Comment 13

3 years ago
Created attachment 8531526 [details]
VIDEO0115_Compress.MP4

This issue has been successfully verified on Flame 2.0:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141202000201
Version         32.0
Device-Name     flame
FW-Release      4.4.2

This issue has been successfully verified on Flame 2.1:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141202001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2

Updated

3 years ago
Status: RESOLVED → VERIFIED
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.