wiki.getPage() returning an empty object, inexplicably, for a valid page path

RESOLVED DUPLICATE of bug 906085

Status

--
major
RESOLVED DUPLICATE of bug 906085
4 years ago
4 years ago

People

(Reporter: sheppy, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
Doing wiki.getPage on /zh-CN/docs/Web_Standards returns an empty object (not null, but an empty object).

See https://developer.mozilla.org/en-US/docs/User:Sheppy/TemplateTests for an example of this in action.

What's happening here? This shouldn't happen. It's breaking macros.
Are all wiki.getPage usages causing a problem, or just this specific URL?
(Reporter)

Comment 2

4 years ago
(In reply to David Walsh :davidwalsh from comment #1)
> Are all wiki.getPage usages causing a problem, or just this specific URL?

Just specific URLs; I've seen two so far, both in the Chinese locale. I do not know if it happens with others.

Updated

4 years ago
Severity: normal → major
As follow up, the problem in this case was an invalid URL -- the page had been moved and contained chinese characters.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 906085
You need to log in before you can comment on or make changes to this bug.