formpost* files not cleaned up in $TMPDIR w/ file submission

VERIFIED DUPLICATE of bug 15320

Status

()

VERIFIED DUPLICATE of bug 15320
17 years ago
17 years ago

People

(Reporter: greg-mozilla, Assigned: rods)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091311

I submitted some files via an HTTP POST on a web site form and mozilla appears
to have created temporary files containing the whole MIME contents of the POST
request in my $TMPDIR.  However, these formpost files are not cleaned up after
successful form submission.

I only see formpost files containing file uploads, not other forms.

the web site in question was password protected but not using ssl.
(sorry, form data and website are private i can't give an example)


Reproducible: Always
Steps to Reproduce:
1. find a website using http file uploads
2. fill out the form, select a few files
3. submit the form
4. exit mozilla
5. notice the formpost files leftover in your $TMPDIR


Actual Results:  5. notice the formpost files leftover in your $TMPDIR


Expected Results:  no formpost files should be left around.


this bug is of privacy and disk space concern.  it doesn't delete its temporary
files that contain a record of what was submitted on a form.

IMHO, these files should -never- be written to disk to begin with.  If you
-really- need temporary storage to submit a form with http file uploads; at
least unlink the file after creating and opening it so that when your last open
reference to its filehandle goes away the file disappears at well.  streaming
the uploaded files direct from disk would be preferred.
Duplicate of "Forms/Necko: Temp file left after file upload"

*** This bug has been marked as a duplicate of 15320 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.