Incorrect interpretation of CSS 'height:' property for boxes

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
18 years ago
18 years ago

People

(Reporter: fullermd, Assigned: dbaron)

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

18 years ago
Per http://www.w3.org/TR/REC-CSS2/visudet.html#propdef-height , a percentage
height: property on a box will give the box that percentage of the size of the
containing block.  However, Mozilla (0.9.4) doesn't appear to honor that.

For a reproduction case, see
http://www.over-yonder.net/~fullermd/bugshowoff/heightbug.html.
The 'heightbug.tar.gz' in the same directory contains the .html and the
associated .css file for download (a hair over 1k).

Interestingly, Opera 5 appears to handle the height: correctly, but glitches in
a different manner by adding a bunch of dead space at the bottom of both columns.
-> style system, although possibly layout?
Assignee: asa → dbaron
Component: Browser-General → Style System
QA Contact: doronr → ian
Does this fall under the "If the height of the containing block is not specified
explicitly (i.e., it depends on content height), the value is interpreted like
'auto'."
Reporter

Comment 4

18 years ago
I'm not entirely sure; the standard gets a bit murky on those fine points.

My understanding of it is that, even in such an event, it should still end up
being the height of the containing block.  The fact that Opera seems to handle
it in the same way as my understanding gives me a bit more faith that my
understanding is correct; it IS possible that we're both flawed in the same way
on it, though.
OK, I'll spend 2 minutes downloading and untarring the testcase (HTML and CSS
attachments directly are preferred -- attach the CSS and then modify your HTML
to point to the attached CSS).
OK, the DIV with ID main has auto height.  -> INVALID.  See the quote I quoted
above.
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → INVALID
(And, BTW, the reason the tarfile is a pain is not because I have to spend 2
minutes once, but because anytime anyone looks at the bug, they have to spend 2
minutes downloading it.  That can add up.  And it often means that a bug will be
ignored, since often one wants to go through a hundred bugs looking for serious
problems)
You need to log in before you can comment on or make changes to this bug.