wget version in MozillaBuild doesn't like https://ftp.m.o

RESOLVED FIXED

Status

mozilla.org
MozillaBuild
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: mt, Assigned: mt)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
This took a while to diagnose, but the problem is a combination of factors: an ancient version of wget and an out of date CA bundle.  Both need updating.

I was able to build a new ca-bundle.crt file using the script from CURL: https://github.com/bagder/curl/blob/master/lib/mk-ca-bundle.vbs

Then I was able to download a recent wget binary from http://eternallybored.org/misc/wget/

I'm reluctant to upload a massive binary patch with all the updated files, but will do so if that makes someone's life any easier.

I'd really like to have us use https URLs for downloading files more often, but that can't happen until our tools support it properly.  On the plus side, this is easy to fix.

Updated

4 years ago
Component: mach → MozillaBuild
Product: Core → mozilla.org
Summary: wget version in mozbuild doesn't like https://ftp.m.o → wget version in MozillaBuild doesn't like https://ftp.m.o
Version: unspecified → other

Comment 1

4 years ago
See also bug 566234.
So the nice thing is that updating these files is a simple matter of checking in new files in the mozilla-build repo:
http://hg.mozilla.org/mozilla-build/file/efb71fed5c28/ca-bundle.crt
http://hg.mozilla.org/mozilla-build/file/efb71fed5c28/wget-1.10.2b.zip
http://hg.mozilla.org/mozilla-build/file/efb71fed5c28/wget-1.10.2s.zip (I believe this is just the source bundle.)
and tweaking the install script if the zip file name changes:
http://hg.mozilla.org/mozilla-build/file/efb71fed5c28/packageit.sh#l94

The downside is that you need to get a new MozillaBuild released to take advantage of it. You might be able to convince RyanVM to do that, though.
Definitely able to be convinced :)

Martin, if you want to submit a patch with just the non-binary changes, I'd be happy to take a look.
(Assignee)

Comment 4

4 years ago
Happy to do so.  I'll include instructions for acquiring the binary parts at the same time.
(Assignee)

Comment 5

4 years ago
Created attachment 8446006 [details] [diff] [review]
bug1029953.patch

My windows machine lives elsewhere, so I haven't tested this, but the changes are trivial.

I have suppressed the binary changes.  You'll need to remove the existing wget zips and then:

http://eternallybored.org/misc/wget/wget-1.15-win32.zip 
  >> wget-1.15b.zip
http://eternallybored.org/misc/wget/src/wget-1.15.tar.xz
  >> wget-1.15s.tar.xz
Assignee: nobody → martin.thomson
Status: NEW → ASSIGNED
Attachment #8446006 - Flags: review?(ryanvm)
Comment on attachment 8446006 [details] [diff] [review]
bug1029953.patch

Review of attachment 8446006 [details] [diff] [review]:
-----------------------------------------------------------------

Looks great, thanks. I can land this for you if you want.
Attachment #8446006 - Flags: review?(ryanvm) → review+
(Assignee)

Comment 7

4 years ago
Please do.  And thanks.
Duplicate of this bug: 566234
Depends on: 1037069
Blocks: 1037069
No longer depends on: 1037069
http://hg.mozilla.org/mozilla-build/rev/ced55786b25e
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
See Also: → bug 1054812
You need to log in before you can comment on or make changes to this bug.