Scrolling with both a background-image and background-color shows the color but not the image

RESOLVED DUPLICATE of bug 1023506

Status

()

defect
RESOLVED DUPLICATE of bug 1023506
5 years ago
5 years ago

People

(Reporter: jlal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
I believe bug 1029542 was a symptom of this problem... Removing the background color (or setting it to transparent) solves the problem. This only reproduces with apz turned on.

The element is screen size with scrollable content with something like this in the DOM:

(Yes it was a data uri in this case)
<div id="content" style="background-image: url('data:....')"></div>

#content {
  border-top: 0.1rem solid #555;
  position: fixed;
  top: 5rem;
  left: 0;
  right: 0;
  bottom: 0;
  overflow: scroll;
  padding-top: 2.4rem;
  background-color: #000000;
  background-size: cover;
}
Do you have a test page already somewhere that reproduces this issue? Either a Gaia app (with or without specific patches applied) or a webpage to be loaded in the browser is fine.
See Also: → 1023506
(Reporter)

Comment 2

5 years ago
You can reproduce this on 2.0 (or master until we land a work around which I can avoid if we commit to fixing this for real in 2.0 which is ideal):

STR:

 > Go to homescreen
 > Long press
 > Add a "Smart Collection" (which one does not matter)
 > Launch Smart Collection
 > Scroll
(Reporter)

Updated

5 years ago
blocking-b2g: --- → 2.0?
Thanks, I'll look into this. Until I investigate a little bit I won't be able to commit to a fix, so it might be worthwhile landing the workaround for now.
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Actually it looks like this is a pretty widespread issue so there might not be much point in landing a homescreen-specific workaround.
The patch on bug 1023506 fixes the disappearing background in the smart collections, as described in comment 2. I think this bug can be duped over to that one, but I'll leave it as a dependency for now until that lands and is verified.
Depends on: 1023506
In the latest master build I can't seem to successfully add any smart collections at all. After picking smart collections from the selection list and hitting done, the collection icons don't appear on my homescreen. However I cooked up an older build with the patches and this bug seems to be fixed.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
No longer depends on: 1023506
Resolution: --- → DUPLICATE
Duplicate of bug: 1023506
blocking-b2g: 2.0? → ---
You need to log in before you can comment on or make changes to this bug.