Optimize the adding of collections to minimize the time before the user can see _something_ on the homescreen as much as possible.

RESOLVED DUPLICATE of bug 1029609

Status

P1
normal
RESOLVED DUPLICATE of bug 1029609
4 years ago
4 years ago

People

(Reporter: jlal, Unassigned)

Tracking

({perf})

unspecified
2.0 S5 (4july)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.0+)

Details

(Whiteboard: [systemsfe][c=progress p= s= u=2.0] )

(Reporter)

Description

4 years ago
My initial plan:

Steps to add a collection:

  - Start an IAC with the collections app asynchronously 

  - When adding a collection return only the collection names without saving to datastore or any other operations that delay the selection of the collection names.

  - Return the collection details in the activity response (with or without the icon not sure....)

  - Show the collection on the homescreen

  - Asynchronously save the collections to the datastore by talking back over IAC to the collections app.

This approach is more complicated but gives us a lot more room for potential perceived performance improvements.

Will measure the current times and work forward from there to ensure we have net gains.
(Reporter)

Comment 1

4 years ago
Bug 1029609 - Will likely be fixed by this or the amount of blank screen time reduced at least.
Blocks: 1029609
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.0?

Updated

4 years ago
Whiteboard: [systemsfe]

Updated

4 years ago
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?]
Keywords: perf
blocking-b2g: 2.0? → 2.0+

Updated

4 years ago
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?] → [VH-FL-blocking-][VH-FC-blocking+]
Vivien - do you have any suggestions before we go down an IAC route here? Something that would be nice would be some way for the activity to hide itself, but continue processing after calling postResult().
Flags: needinfo?(21)
OS: Mac OS X → Gonk (Firefox OS)
Priority: -- → P1
Hardware: x86 → ARM
Whiteboard: [systemsfe] → [systemsfe][c=progress p= s= u=]
Whiteboard: [systemsfe][c=progress p= s= u=] → [systemsfe][c=progress p= s= u=2.0]
Status: NEW → ASSIGNED
(Reporter)

Comment 3

4 years ago
In my less then scientific test (since it requires me to actually choose an item) it takes 10-12 seconds before the home-screen _begins_ to display an icon.
(Reporter)

Comment 4

4 years ago
Not going to be working on this (ended up working on something else today and my time for 2.0 is up) Even with 4s of that 10-12 being geolocation timeout we have a 4-6ss~ overhead.
Assignee: jlal → nobody
No longer blocks: 1028452
Since this was an investigation I'm going to close in favor of tracking this in bug 1029609 - I don't really feel like a spin-off is needed at this time. Thank you for looking into this James.
No longer blocks: 1029609
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(21)
Resolution: --- → DUPLICATE
Duplicate of bug: 1029609

Updated

4 years ago
Target Milestone: --- → 2.0 S5 (4july)
You need to log in before you can comment on or make changes to this bug.