Closed Bug 103007 Opened 18 years ago Closed 18 years ago

All tabs in a window have the same values for the Link Toolbar of the last tab loaded

Categories

(SeaMonkey :: Tabbed Browser, defect, minor)

x86
Windows 98
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 102905

People

(Reporter: elmetatron, Assigned: hyatt)

References

()

Details

All the tabs in a window have the same values for the Link Toolbar of the last
tab loaded.  Instead each tab should have their own values for the Link Toolbar.
 The user must reload the prior tabs in order for the Link Toolbar to have the
correct values for that page.

Reproducible: Always
Steps to Reproduce:
1. Load a site that has the link element (ie: http://www.w3.org/).
2. Press ctrl-t to open a new tab.
3. Load a site that has the link element in the second tab (ie:
http://www.htmlhelp.com/links/tutorials.htm).
4. Switch back to the first tab.
5. Click on any of the Link Toolbar's icon's and notice that it gives the values
for the second tab that was loaded and loads that in the active tab window.

Actual Results: The Link Toolbar has incorrect values for every tab except the
last tab loaded.

Expected Results: The Link Toolbar should have the correct values for every tab.
Duplicate of "Link toolbar doesn't update when tabs are switched"

*** This bug has been marked as a duplicate of 102905 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.