If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Starting DOM inspector causes crash

RESOLVED DUPLICATE of bug 101896

Status

Other Applications
DOM Inspector
--
critical
RESOLVED DUPLICATE of bug 101896
16 years ago
10 years ago

People

(Reporter: Roland Mainz, Assigned: Joe Hewitt (gone))

Tracking

Trunk
Future
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
2001-10-02-08-trunk build on Solaris 7 with Sun Workshop 6 Update 2.
Starting the DOM Inspector via context menu kills the Zilla like this:
-- snip --
ocument http://tinderbox.mozilla.org/SeaMonkey-Ports/ loaded successfully
###!!! ASSERTION: need base URL: 'nsnull != aBaseURL', file
../../../../../../../src/2001-10-02-08-trunk/mozilla/content/html/style/src/nsCSSParser.cpp,
line 791
###!!! Break: at file
../../../../../../../src/2001-10-02-08-trunk/mozilla/content/html/style/src/nsCSSParser.cpp,
line 791
###!!! ASSERTION: need base URL: 'nsnull != aBaseURL', file
../../../../../../../src/2001-10-02-08-trunk/mozilla/content/html/style/src/nsCSSParser.cpp,
line 791
###!!! Break: at file
../../../../../../../src/2001-10-02-08-trunk/mozilla/content/html/style/src/nsCSSParser.cpp,
line 791
WEBSHELL+ = 6
###!!! ASSERTION: Attempt to decrement focus controller's suppression when no
suppression active!
: 'PR_FALSE', file
../../../../../../src/2001-10-02-08-trunk/mozilla/dom/src/base/nsFocusController.cpp,
line 416
###!!! Break: at file
../../../../../../src/2001-10-02-08-trunk/mozilla/dom/src/base/nsFocusController.cpp,
line 416
xxlib_find_handle: 'xxlib-default' entry e82628
Document http://tinderbox.mozilla.org/SeaMonkey/ loaded successfully
WEBSHELL- = 5
Document http://www.mozilla.org/ loaded successfully
xxlib_find_handle: 'xxlib-default' entry e82628
WEBSHELL+ = 6
xxlib_find_handle: 'xxlib-default' entry e82628
Error reading file
jar:resource:///chrome/inspector.jar!/skin/classic/inspector/viewerPane.css
WARNING: CSSLoaderImpl::DidLoadStyle: Load of URL
'chrome://inspector/skin/viewerPane.css' failed.  Error code: 6, file
../../../../../../../src/2001-10-02-08-trunk/mozilla/content/html/style/src/nsCSSLoader.cpp,
line 932
JavaScript error: 
chrome://communicator/content/utilityOverlay.js line 1: redeclaration of const
kIOServiceProgID

WEBSHELL+ = 7
WEBSHELL+ = 8
xxlib_find_handle: 'xxlib-default' entry e82628
xxlib_find_handle: 'xxlib-default' entry e82628
WEBSHELL+ = 9
WEBSHELL+ = 10
xxlib_find_handle: 'xxlib-default' entry e82628
xxlib_find_handle: 'xxlib-default' entry e82628
JavaScript error: 
chrome://global/content/bindings/outliner.xml#outliner.firstOrdinalColumn
(getter) line 3: cols[0] has no properties

ld.so.1: ./mozilla-bin: fatal: relocation error: file
/home/mozilla/builds/2001-10-02-08-trunk/objdir_ws6_xlib/dist/bin/components/libgkcontent.so:
symbol __1cIDistance6FrknRnsReadingIterator4CH__2_I_: referenced symbol not
found
Killed
-- snip --

-- snip --
% dem __1cIDistance6FrknRnsReadingIterator4CH__2_I_:
__1cIDistance6FrknRnsReadingIterator4CH__2_I_: == unsigned Distance(const
nsReadingIterator<unsigned short>&,const nsReadingIterator<unsigned short>&)
-- snip --
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Reporter)

Comment 1

16 years ago
This is a duplicate of bug 101896 ...

*** This bug has been marked as a duplicate of 101896 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → Other Applications
QA Contact: timeless → dom-inspector
You need to log in before you can comment on or make changes to this bug.