Keyboard gets stuck after submitting a form by pressing the enter key

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::Keyboard
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: cwiiis, Assigned: rudyl)

Tracking

({regression})

unspecified
2.0 S6 (18july)
All
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
If you submit any form by hitting enter with the keyboard, the keyboard will become permanently stuck on screen until you either

a) Focus another text entry (whereby the long-press space or tapping outside of the entry will resume functioning)
b) Switch input method via the system tray

There doesn't appear to be any other ways of hiding the keyboard again once stuck in this state (and b is not at all obvious a work-around).

Need to verify this happens in 2.0, but I think it does.
Chris - Can you provide an example STR you used to reproduce this?
Flags: needinfo?(chrislord.net)
(Reporter)

Comment 2

4 years ago
(In reply to Jason Smith [:jsmith] from comment #1)
> Chris - Can you provide an example STR you used to reproduce this?

Sorry, I don't know how I managed to miss this bit out...

STR:

1. Go to bugzilla.mozilla.org
2. Type anything into the search field and press the enter key

Expected:

Form submits, keyboard disappears

Actual:

Form submits, keyboard remains in position and becomes impossible to hide (long-press spacebar stops working, tapping on the page stops working). You can hide it using the work-arounds listed in comment #0.
Flags: needinfo?(chrislord.net)
QA Wanted to check on 2.0.
Keywords: qawanted
Issue occurs on Flame 2.1, Buri 2.1, and Open C 2.1.

Test results: When searching for a specific bug number on Bugzilla and hitting enter button on keyboard, keyboard does not hide itself after executing the search. This only occurs when searching for a bug number. When searching for words like 'crash' or 'browser', keyboard correctly hides itself after executing search.

Device: Flame
Build ID: 20140625064003
Gaia: 1bcd355855626640b2532f2ccb1f814711f7a6ad
Gecko: da1dbcff9493
Version: 33.0a1 (Master)
Firmware Version: v122

Device: Buri
Build ID: 20140625064003
Gaia: 1bcd355855626640b2532f2ccb1f814711f7a6ad
Gecko: da1dbcff9493
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg

Device: Open_C
Build ID: 20140625064003
Gaia: 1bcd355855626640b2532f2ccb1f814711f7a6ad
Gecko: da1dbcff9493
Version: 33.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL

-----------------------------------------------------------

Issue does not occur on Flame 2.0, Buri 2.0, and Open C 2.0.

Test results: Keyboard correctly hides itself after executing various searches via keyboard's enter button on Bugzilla.

Device: Flame
Build ID: 20140625000201
Gaia: de77f794db22a45f9d575de2c6e266a30a50de3b
Gecko: 79712bd7b60d
Version: 32.0a2 (2.0)
Firmware Version: v122

Device: Buri
Build ID: 20140625000201
Gaia: de77f794db22a45f9d575de2c6e266a30a50de3b
Gecko: 79712bd7b60d
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg

Device: Open_C 2.0
Build ID: 20140625000201
Gaia: de77f794db22a45f9d575de2c6e266a30a50de3b
Gecko: 79712bd7b60d
Version: 32.0a2 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted → regression
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted

Updated

4 years ago
blocking-b2g: 2.0? → 2.1?
QA Contact: pcheng
b2g inbound regression window:

Last Working Environmental Variables:
Device: Buri
Build ID: 20140610232710
Gaia: 207cacb0dc5f320a02e7ef979233ebd4ab6bbbd5
Gecko: 9df71ad3f13e
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg

First Broken Environmental Variables:
Device: Buri
BuildID: 20140610235510
Gaia: f60210825f0840f95819f47a878b165019f232e9
Gecko: 90fcde49f5f4
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg

First broken gecko and last working gaia - issue does NOT repro
Gaia: 207cacb0dc5f320a02e7ef979233ebd4ab6bbbd5
Gecko: 90fcde49f5f4

Last working gecko and first broken gaia - issue DOES repro
Gaia: f60210825f0840f95819f47a878b165019f232e9
Gecko: 9df71ad3f13e

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/207cacb0dc5f320a02e7ef979233ebd4ab6bbbd5...f60210825f0840f95819f47a878b165019f232e9

The only bug in the pushlog is bug 1022475, so nominating this as the culprit.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Broken by bug 1022475   Tim, can you take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(timdream)

Updated

4 years ago
Blocks: 1022475
Rudy, could you take this? You should understand that patch well enough since you review the patch.

Tell me if you cannot or you are overwhelmed by anything more important than 2.1+.
Flags: needinfo?(timdream) → needinfo?(rlu)
Sure, take it.
Assignee: nobody → rlu
Flags: needinfo?(rlu)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
I found this is a interesting bug when I tried to reproduce it.
Thanks for the info from comment 4 that need to input number so that you could be hit by this issue.
However, it is not about the content, but about on what panel (symbol or default) you press the [Enter] key.

So, modify the steps as follows,
-----
1. Go to a input field, like bugzilla search field or Google search.
2. Type anything, not matter it is alphabet or number.
3. Switch to symbol panel (with numbers and symbols) by pressing [12&] key.
4. Press Enter on that panel.
   => Should be able to reproduce this issue.
Status: NEW → ASSIGNED
Target Milestone: --- → 2.0 S6 (18july)
Created attachment 8450886 [details] [review]
WIP

WIP to see how the CI goes.
Comment on attachment 8450886 [details] [review]
WIP

[Root Cause]
The keyboard app would send resize request because it switched back to the default panel (after pressing [Enter] in symbol panel).
When the keyboard manager receive an resize request (mozbrowserresize event) after the keyboard is hiding, it should ignore this request.

I did not block the resize request in InputAppsTransitionManager because it may receive resize request from setKeyboardToShow() function in keyboardManager.

Tim,

Could you help review if this is a proper fix?
Thank you.
Attachment #8450886 - Flags: review?(timdream)
Comment on attachment 8450886 [details] [review]
WIP

Sounds like a acceptable solution because we probably shouldn't do big refactor in a regression bug.
Attachment #8450886 - Flags: review?(timdream) → review+
Merge it to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/043f8009630df560132852c00cba1b3ab67306e5

--
The Travis failure should be irrelevant,
https://travis-ci.org/mozilla-b2g/gaia/jobs/29230621
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.1: affected → fixed
Resolution: --- → FIXED
Triage: regression.
blocking-b2g: 2.1? → 2.1+
This bug is verified fixed in Flame 2.1 KK as well as a precautionary check on Flame 2.2 KK. Tested with Fullflash and 319mb.

The keyboard does not linger around when the user goes to a search field and switches to the numerical or symbols or alphabetical keyboards, types some information (ie. bug numbers) then taps the Enter key. The keyboards are disappearing correctly. This has been tested on the following sites: bugzilla.mozilla.org and Google.com

Repro Rate: 0/12

Device: Flame 2.2 KK
BuildID: 20141013040202
Gaia: 3b81896f04a02697e615fa5390086bd5ecfed84f
Gecko: f547cf19d104
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
-----------------------------------------------------------------
Device: Flame 2.1 KK
BuildID: 20141013001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: --- → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.