All users were logged out of Bugzilla on October 13th, 2018

Intermittent browser_hotfix.js | application crashed [@ nsSocketTransport::InitiateSocket()]

RESOLVED DUPLICATE of bug 1027287

Status

()

RESOLVED DUPLICATE of bug 1027287
4 years ago
4 years ago

People

(Reporter: cbook, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
Ubuntu VM 12.04 x64 mozilla-inbound pgo test mochitest-browser-chrome-3 on 2014-06-25 03:28:50 PDT for push b19674e5222c

slave: tst-linux64-spot-426

https://tbpl.mozilla.org/php/getParsedLog.php?id=42433578&tree=Mozilla-Inbound

03:35:00  WARNING -  PROCESS-CRASH | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | application crashed [@ nsSocketTransport::InitiateSocket()]

03:35:00     INFO -  Operating system: Linux
03:35:00     INFO -                    0.0.0 Linux 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64
03:35:00     INFO -  CPU: amd64
03:35:00     INFO -       family 6 model 44 stepping 2
03:35:00     INFO -       1 CPU
03:35:00     INFO -  Crash reason:  SIGSEGV
03:35:00     INFO -  Crash address: 0x0
03:35:00     INFO -  Thread 4 (crashed)
03:35:00     INFO -   0  libxul.so!nsSocketTransport::InitiateSocket() [nsSocketTransport2.cpp:b19674e5222c : 1198 + 0x0]
03:35:00     INFO -      rbx = 0x00007f540a5d8f20   r12 = 0x00007f542ba80c80
03:35:00     INFO -      r13 = 0x00007f540a5d8fb0   r14 = 0x00007f54553cdbd0
03:35:00     INFO -      r15 = 0x00007f54494e1a00   rip = 0x00007f545218120f
03:35:00     INFO -      rsp = 0x00007f54456fe990   rbp = 0x00007f54456feb60
03:35:00     INFO -      Found by: given as instruction pointer in context
03:35:00     INFO -   1  libxul.so!nsSocketTransport::OnSocketEvent(unsigned int, tag_nsresult, nsISupports*) [nsSocketTransport2.cpp:b19674e5222c : 1723 + 0x7]
03:35:00     INFO -      rbx = 0x00007f540a5d8f20   r12 = 0x00007f544571c920
03:35:00     INFO -      r13 = 0x0000000000000000   r14 = 0x00007f54553cdbd0
03:35:00     INFO -      r15 = 0x00007f54494e1a00   rip = 0x00007f54521813d4
03:35:00     INFO -      rsp = 0x00007f54456feb70   rbp = 0x00007f54456feb90
03:35:00     INFO -      Found by: call frame info
03:35:00     INFO -   2  libxul.so!nsSocketEvent::Run() [nsSocketTransport2.cpp:b19674e5222c : 82 + 0x4]
03:35:00     INFO -      rbx = 0x00007f5456e89880   r12 = 0x00007f54456fec40
03:35:00     INFO -      r13 = 0x00007f5452181620   r14 = 0x0000000000000001
03:35:00     INFO -      r15 = 0x00007f54494e1a00   rip = 0x00007f5452181637
03:35:00     INFO -      rsp = 0x00007f54456feba0   rbp = 0x00007f54456feba0
03:35:00     INFO -      Found by: call frame info
03:35:00     INFO -   3  libxul.so!nsThread::ProcessNextEvent(bool, bool*) [nsThread.cpp:b19674e5222c : 766 + 0x2]
03:35:00     INFO -      rbx = 0x00007f5456e89880   r12 = 0x00007f54456fec40
03:35:00     INFO -      r13 = 0x00007f5452181620   r14 = 0x0000000000000001
03:35:00     INFO -      r15 = 0x00007f54494e1a00   rip = 0x00007f5451e55c1a
03:35:00     INFO -      rsp = 0x00007f54456febb0   rbp = 0x00007f54456fec30
03:35:00     INFO -      Found by: call frame info
03:35:00     INFO -   4  libxul.so!NS_ProcessNextEvent(nsIThread*, bool) [nsThreadUtils.cpp:b19674e5222c : 263 + 0xd]
03:35:00     INFO -      rbx = 0x0000000000000001   r12 = 0x00007f5456e89870
03:35:00     INFO -      r13 = 0x00007f5456e898b8   r14 = 0x0000000000000000
03:35:00     INFO -      r15 = 0x00007f54494e1a00   rip = 0x00007f5451e3fcce
03:35:00     INFO -      rsp = 0x00007f54456fec40   rbp = 0x00007f54456fec60
03:35:00     INFO -      Found by: call frame info
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 4

4 years ago
The [@ nsSocketTransport::InitiateSocket()] means something has hit the new feature added in bug 995417 - look at the log for "Non-local network connections are disabled and a connection attempt to XYZ" - bug 1026987 will make these appear in the error summary.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1027287
Comment hidden (Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.