[Rocketbar] Search term will show brackets for searches that have the two of the same words or content

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Search
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: nhirata, Assigned: ranbena)

Tracking

({regression})

unspecified
2.0 S5 (4july)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

Created attachment 8445940 [details]
2014-06-25-09-02-53.png

1. make sure search suggestion is turned on
2. tap the rocketbar
3. type in "para para"

Expected: para para paradise
Actual: [para][para] [para][para][para]dise

Note:
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
There's a related bug in regards to typing in brackets and not getting related [ ]'s.

ie type [Him]

I'm not 100 % sure if there's a strong case for this, or if it should be separated from this bug or not.
In essense, [] explicitly and implicitly in the search suggestions aren't handled well.
Tested on:
Gaia      de77f794db22a45f9d575de2c6e266a30a50de3b
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/79712bd7b60d
BuildID   20140625000201
Version   32.0a2
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
flame
QA Wanted - Did this problem reproduce on 1.4 with the old e.me search implementation?
Keywords: qawanted

Updated

4 years ago
Blocks: 1015336
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?]
(In reply to Jason Smith [:jsmith] from comment #3)
> QA Wanted - Did this problem reproduce on 1.4 with the old e.me search
> implementation?

Checked on v1.4 - doesn't reproduce.
(In reply to Ran Ben Aharon (Everything.me) from comment #4)
> (In reply to Jason Smith [:jsmith] from comment #3)
> > QA Wanted - Did this problem reproduce on 1.4 with the old e.me search
> > implementation?
> 
> Checked on v1.4 - doesn't reproduce.

Ok - we probably should block on this, as this is a parity issue with the old implementation.
blocking-b2g: --- → 2.0?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?] → [VH-FL-blocking-][VH-FC-blocking+]
Keywords: qawanted → regression
Created attachment 8447589 [details] [review]
Pull request
Attachment #8447589 - Flags: review?(kgrandon)
It seems e.me server responds with multiple brackets in cases like these. Might be a server logic bug.
"[[para]] [[para]]"

This patch fixes it client side.
Comment on attachment 8447589 [details] [review]
Pull request

It would be good to follow this up with an integration test perhaps. But perhaps we can take care of that since you're going on PTO for a bit soon.
Attachment #8447589 - Flags: review?(kgrandon) → review+
Landed: https://github.com/mozilla-b2g/gaia/commit/b3c01bb6257b124fd8b558185148bcf4aaa720e3
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
We've also fixed the server bug (so now responses contain only single brackets).

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+

Updated

4 years ago
Whiteboard: [systemsfe]
v2.0: https://github.com/mozilla-b2g/gaia/commit/7bb0327d558dab0af32ded80c6ab9b699ad35cb8
Assignee: nobody → ran
status-b2g-v2.0: affected → fixed
status-b2g-v2.1: affected → fixed
Target Milestone: --- → 2.0 S5 (4july)
Hrm.  1.4 version doesn't care about [] so I guess we can ignore issue in comment 1.

Marking this as verified fixed:
Gaia      34a52e7f024cc3d0e3aade94970773d2555f5ccb
Gecko     https://hg.mozilla.org/mozilla-central/rev/ffb8b976548b
BuildID   20140701072955
Version   33.0a1
ro.build.version.incremental=eng..20140508.024737
ro.build.date=Thu May  8 02:48:06 CST 2014
Open C

Gaia      8fb5e2a9ad1025ee7d247b90af7499766afadd28
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/5da69a493324
BuildID   20140701000201
Version   32.0a2
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220
Flame
Status: RESOLVED → VERIFIED
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.