Add low-DPI Yahoo logo to search plugin so about:newtab can use it

VERIFIED FIXED in Firefox 31

Status

()

Firefox
Search
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: adw, Assigned: adw)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 33
Points:
1
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox30 unaffected, firefox31+ verified, firefox32+ verified, firefox33 verified)

Details

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
Created attachment 8445988 [details] [diff] [review]
patch

All the search providers shown in about:newtab by default have both low- and high-DPI logo images except for Yahoo, which has only a high-DPI image (landed in bug 1009299).  The reason is that I wanted to let bug 1009266 downsample the image instead, but there are a couple of problems with that: (1) the high-DPI image is on 31 but bug 1009266 is on 32, so on 31, the Yahoo image just doesn't appear at all, and (2) bug 1027791 points out that downsampling is a bad UX right now and may even hurt performance.
Attachment #8445988 - Flags: review?(MattN+bmo)
(Assignee)

Updated

4 years ago
QA Whiteboard: [qa+]
status-firefox30: --- → unaffected
status-firefox31: --- → affected
status-firefox32: --- → affected
tracking-firefox31: --- → ?
tracking-firefox32: --- → ?
(Assignee)

Comment 1

4 years ago
For the record, in addition to bug 1027791, Avi talks about the Yahoo logo downsampling problems in specific in bug 1019990 comment 16 and earlier.
(Assignee)

Comment 2

4 years ago
Marco, could we add this to the current iteration, please?
Flags: needinfo?(mmucci)
Flags: firefox-backlog+
Comment on attachment 8445988 [details] [diff] [review]
patch

Thanks. I was going to ask about the inconsistency in the past.
Attachment #8445988 - Flags: review?(MattN+bmo) → review+
Added to Iteration 33.2
Flags: needinfo?(mmucci)
Tracking because it is a new feature and adding an icon should be low risk.
tracking-firefox31: ? → +
tracking-firefox32: ? → +
QA Contact: petruta.rasa
https://hg.mozilla.org/mozilla-central/rev/725e50a3bfc1
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
(Assignee)

Comment 8

4 years ago
Comment on attachment 8445988 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
Bug 962490 added a search field to about:newtab and landed on 31.  The logo of the currently selected search engine, if available, appears to the left of the search field.

User impact if declined:
On 31, when Yahoo is the currently selected engine, its logo will not appear if the user's display is low-DPI.  about:newtab gracefully handles missing logos, though.  On 32, the logo will appear, but the user may notice a slight flicker due to downsampling the high-DPI logo as described in bug 1009299.

Testing completed (on m-c, etc.):
manual testing, automated testing on m-c

Risk to taking this patch (and alternatives if risky):
very low

String or IDL/UUID changes made by this patch:
none
Attachment #8445988 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 9

4 years ago
Created attachment 8446636 [details] [diff] [review]
Beta patch

Bug 998071 landed on 32 and changed yahoo.xml, which made the m-c/Aurora patch not apply cleanly to Beta.

[Approval Request Comment]
see comment 8
Attachment #8446636 - Flags: approval-mozilla-beta?
status-firefox33: --- → fixed
Attachment #8446636 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #8445988 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified that the Yahoo logo is displayed on about:newtab page when it is chosen from the search list.

Environments: Win 7 64-bit, Ubuntu 12.10 32-bit, Mac OSX 10.9.3
Builds: Firefox 31 beta 5, latest Aurora 20140629081512, latest Nightly 20140629030206
Status: RESOLVED → VERIFIED
QA Whiteboard: [qa+] → [qa!]
status-firefox31: fixed → verified
status-firefox32: fixed → verified
status-firefox33: fixed → verified
You need to log in before you can comment on or make changes to this bug.