Closed Bug 1030415 Opened 5 years ago Closed 5 years ago

Stuck in Camera when unlocking to camera then unlocking normally if SIM card has a PIN

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
blocking-b2g 2.0+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: jlorenzo, Assigned: alive)

References

Details

(Keywords: regression)

Attachments

(3 files)

Build info
Device: Flame
Gaia      c5dd47e3f9e18872961946735fdbc071a1656ac9
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/71b1b4b0850c
BuildID   20140620000202
Version   32.0a2
ro.build.version.incremental=eng..20140429.025303
ro.build.date=Tue Apr 29 02:53:29 CST 2014

Prerequisites: 
Having a PIN on one of the SIM card.

STR
1. Restart the phone (or put on then off Airplane mode and press lock button)
2. Unlock to Camera.
3. Press lock button
4. Unlock the device.
5. Enter your PIN.
6. Tap (or long press) home button.

Expected result
You are redirected to the homescreen (or card views).

Actual result
Pressing this button has no effect. The focus seems to be not on the camera anymore. This prevents the user from quitting this app. See video for details.

Video Link: http://mzl.la/1lQK7Hy
QA Wanted to check if it's reproducible on 1.4.
Keywords: qawanted
This bug repro's on: Flame 2.1 Master, Flame 2.0, OpenC 2.1, OpenC 2.0, 

Actual Result: After unlocking the phone with the Pin, the user can NOT use the home button to leave the Camera app.

Environmental Variables:
Device: Flame Master
Build ID: 20140625064003
Gaia: 1bcd355855626640b2532f2ccb1f814711f7a6ad
Gecko: da1dbcff9493
Version: 33.0a1 (Master)
Firmware Version: v122
------------------------------------------
Environmental Variables:
Device: Flame 2.0
Build ID: 20140625103007
Gaia: ae8c3876b78de6f1a0b9899ce05826601a42d438
Gecko: 13c4804465d6
Version: 32.0a2 (2.0)
Firmware Version: v122
------------------------------------------
Environmental Variables:
Device: Open_C Master
Build ID: 20140625064003
Gaia: 1bcd355855626640b2532f2ccb1f814711f7a6ad
Gecko: da1dbcff9493
Version: 33.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
------------------------------------------
Environmental Variables:
Device: Open_C 2.0
Build ID: 20140625103007
Gaia: ae8c3876b78de6f1a0b9899ce05826601a42d438
Gecko: 13c4804465d6
Version: 32.0a2 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL

-------------------------------------------
-------------------------------------------

This bug does NOT repro on: Flame 1.4, Buri 2.1 Master, Buri 2.0, Buri 1.4

Actual Results: After unlocking the phone with the Pin, the user can use the home button to leave the Camera app.

Environmental Variables:
Device: Flame 1.4
Build ID: 20140625000201
Gaia: c9416de14acf9e94ab006619cd2418c768422fcb
Gecko: cddf88f78632
Version: 30.0 (1.4)
Firmware Version: v122
------------------------------------------
Environmental Variables:
Device: Buri Master
Build ID: 20140625064003
Gaia: 1bcd355855626640b2532f2ccb1f814711f7a6ad
Gecko: da1dbcff9493
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg
-------------------------------------------
Environmental Variables:
Device: Buri 2.0
Build ID: 20140625124605
Gaia: c478c43229883cee2afd09c6edb42d29a46cc500
Gecko: 8940337ccb5c
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
-------------------------------------------
Environmental Variables:
Device: Buri 1.4
Build ID: 20140625101108
Gaia: 4979e8d625aed26ebf2aefbf4c86c9b8412f58ce
Gecko: 223fbb1649f6
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg


***OpenC 1.4 results to follow in the next comment
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
nomming as a 2.0 blocker; issue seems to have a significant impact as the user is unable to quit the app.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Blocking on the issue
blocking-b2g: 2.0? → 2.0+
    Bug Does not repro on OpenC 1.4.

    Actual Results: The home button can be used to exit the camera app after entering the SIM pin.
QA Contact: croesch → pcheng
Unable to get a regression window due to:

1) earlier Flame Central Tinderbox builds don't recognize SIM, and

2) the earliest tinderbox Flame central builds that we have available is on 4/17, and on 4/17 Flame Central had already become 2.0 (central became 2.0 on 3/17). This bug occurred between 1.4 and 2.0.

We can't use Buri because it does not occur on Buri.

Removing window-wanted tag.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Duplicate of this bug: 1024399
Hi Tim, please help to assign this, thanks
Flags: needinfo?(timdream)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Alive says he can help.
Assignee: nobody → alive
Status: NEW → ASSIGNED
Flags: needinfo?(timdream)
BTW, I cannot repro on v2.1 but v2.0
I suspect there is timing issue - now I cannot repro on flame 1.4
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #11)
> I suspect there is timing issue - now I cannot repro on flame 1.4

Some observation:
* You don't need to access unlock dialog - just need to open camera and you cannot use home button to back to home
* This only occur at first time you try to do this after rebooting.
Root cause:
homescreenopened event and appopened event of camera app is racing to let AppWindowManager update the wrong active app.

Idea:
homescreen should not be opened if the lockscreen is opening camera.
A proper fix needs a new event: lockscreen-request-close and tell it's launching camera or not.
Then we could let VisibilityManager use it instead of lockscreen-appclosing
Attached file master patch
v1: Use lockscreen-request-unlock in visibility manager to identify the next app is home or app.
Attachment #8449193 - Flags: review?(timdream)
Attachment #8449193 - Flags: review?(timdream) → review+
Needs a specific patch for 2.0, doing.
Attached file v2.0 patch
master https://github.com/mozilla-b2g/gaia/commit/1ceb4ba53cea0469910b8c9c7668b1833adc75e3
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
No longer blocks: 1036236
Depends on: 1036236
Depends on: 1035739
Hi Reporter,
    We can't open the video link: http://mzl.la/1lQK7Hy .Could you check the STR for me to verify this bug?

Thank you!

STR:
1. Restart the phone.
2. Unlock to Camera.
3. Press Power key for locking.
4. Slide to the right for unlocking the device.
5. Enter SIM PIN1.
6. Tap (or long tap) Home button.

Actual result:
5.Into Camera screen.
6.Go to Home screen(or camera app thumbnail).
Flags: needinfo?(jlorenzo)
Hi Johan,

Please ignore comment 20.


This issue has been successfully verified on Flame v2.1&v2.0.
See attachment: verified_v2.1.mp4
Reproducing rate: 0/5

Flame2.0 build:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141127000203
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141127.034818
FW-Date         Thu Nov 27 03:48:29 EST 2014
Bootloader      L1TC00011880

Flame2.1 build:
Gaia-Rev        5372b675e018b6aac97d95ff5db8d4bd16addb9b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/f34377ae402b
Build-ID        20141127001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141127.035005
FW-Date         Thu Nov 27 03:50:16 EST 2014
Bootloader      L1TC00011880
Status: RESOLVED → VERIFIED
Per comment 21.
Flags: needinfo?(jlorenzo)
You need to log in before you can comment on or make changes to this bug.