Closed Bug 1030429 Opened 5 years ago Closed 5 years ago

repeatedly scrolling while hitting home button locks up the UI

Categories

(Core :: Panning and Zooming, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1030221
Tracking Status
b2g-v2.0 --- affected

People

(Reporter: ladamski, Unassigned)

References

Details

build: aurora 20140625000201

Alternating between scrolling down and hitting the home button eventually locks up the UI.  This usually takes 5-10 seconds of trying.

The outcome varies.  Sometimes the UI is completely non-interactive, sometimes it won't scroll but you can launch.  Usually locking and unlocking the phone fixes it (but once it didn't and required a reboot).
blocking-b2g: --- → 2.0?
This looks like a Core: Panning and Zooming issue. Can you confirm Kevin?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
I think so. I've seen something similar happen where we stop being able to scroll a page, but no STR yet. I'm scrolling the homescreen as we speak. We might have to give Lucas a gecko with DEBUG turned on for APZ to get some useful logging.
Component: Gaia::Homescreen → Panning and Zooming
Product: Firefox OS → Core
Kats - have you by chance seen this or are you aware of anything this may be a dupe of?
Flags: needinfo?(bugmail.mozilla)
FWIW - this appears to be pretty easy to reproduce. Just constantly scroll down and press the home button. Repeat for a few minutes.
First I'm hearing of this. Can somebody include a video of the STR? I spent a few minutes trying on a hamachi and was unable to repro.
Flags: needinfo?(bugmail.mozilla)
QA Wanted for a video.
Blocks: 1015336
No longer blocks: vertical-homescreen
Keywords: qawanted
I can reproduce with overscroll turned on, without that it seems like I can't.
Here is the link for the video showing the scrolling lock up.
http://youtu.be/3ovISuisPCQ

This scrolling lock up looks like it takes a lot of work to get, but I have got this only after 2 swipes just did not get that on video.

I couldn't find anything about overscrolling but if it's not on by default then I did not have it enabled.
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+] → [VH-FL-blocking-][VH-FC-blocking+][QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
Here are the environmental variables this was seen on:

Environmental Variables:
Device: Flame Master
Build ID: 20140625064003
Gaia: 1bcd355855626640b2532f2ccb1f814711f7a6ad
Gecko: da1dbcff9493
Version: 33.0a1 (Master)
Firmware Version: v122
QA-Wanted for branch/device checks
Flags: needinfo?(jmitchell)
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+][QAnalyst-Triage?] → [VH-FL-blocking-][VH-FC-blocking+]
Keywords: qawanted
(In reply to Joshua Mitchell from comment #10)
> QA-Wanted for branch/device checks

Vivien's comment indicates that this only reproduces with overscroll enabled, which means this will reproduce on 2.0, not 1.4.
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+] → [VH-FL-blocking-][VH-FC-blocking+][QAnalyst-Triage+][lead-review+]
Keywords: qawanted
Clearing VH flags since this is APZC issue, not a vertical homescreen bug.
No longer blocks: 1015336
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+][QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage+][lead-review+]
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
This has the same root cause as bug 1030221. Duping over; that one is already 2.0+
Status: NEW → RESOLVED
blocking-b2g: 2.0? → ---
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1030221
You need to log in before you can comment on or make changes to this bug.