[B2G][WAP Push][OMA Provisioning] When using the CHT_MMS profile in messaging settings, no MMS messages can be received on the DUT

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
7 months ago

People

(Reporter: dharris, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3 affected, b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [2.0-flame-test-run-2][2.1-flame-test-run-1], URL)

Attachments

(1 attachment)

Created attachment 8446226 [details]
OMALogcat.txt

Description:
The user cannot receive or send any MMS messages from a device that has the CHT_MMS profile set up in messaging settings, however SMS will work as intended

Repro Steps:
1) Update a Flame to BuildID: 20140610000223
2) Open NowSMS on PC, go to "OMA provisioning content". Fill in following items then send to DUT: 
- Connection Type: GPRS 
- Settings Name: CHT_MMS 
- GPRS Access Point Name: emome 
- WAP Proxy IP Address : 10.1.1.1 
- WAP Proxy Port: 8080 
- MMS Message Server URL: http://mms:8002 
- OTA PIN:1234 
- OTA PIN Type: Check User PIN
3) On the DUT type in the pin and select Accept>  then store the CHT_MMS Profile
4) Open Settings App> Cellular & Data> Messaging Settings> Select CHT_MMS> Then tap ok
5)Send or receive an MMS to DUT

Actual:
MMS is never received or sent on the DUT

Expected:
User can send or receive messages without issue when using the CHT_MMS profile

Flame 2.0

2.0 Environmental Variables:
Device: Flame 2.0
Build ID: 20140625000201
Gaia: de77f794db22a45f9d575de2c6e266a30a50de3b
Gecko: 79712bd7b60d
Version: 32.0a2 (2.0)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Keywords: WAP Push, OMA Provisioning Content, Configuration, OTA, IMSI

Repro frequency: 15/15 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/10629/
See attached: Logcat, Video - https://www.youtube.com/watch?v=1Q9rZOsmVYk
This issue DOES reproduce on Flame 2.1, Buri 2.1, Open C 2.1, Buri 2.0, Open C 2.0, Flame 1.4, Buri 1.4, Open C 1.4,  Open C 1.3 Base, and Buri 1.3

When a device recieves the CHT_MMS profile and uses it, the device will be unable to receive MMS messages

Flame 2.1

2.1 Environmental Variables:
Device: Flame Master
Build ID: 20140625040202
Gaia: 57da30f405ba37a5d4844f32bb292271b81faee2
Gecko: a19e0434ea52
Version: 33.0a1 (Master)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Buri 2.1

2.1 Environmental Variables:
Device: Buri Master
Build ID: 20140625040202
Gaia: 57da30f405ba37a5d4844f32bb292271b81faee2
Gecko: a19e0434ea52
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Open_C 2.1

2.1 Environmental Variables:
Device: Open_C Master
Build ID: 20140625040202
Gaia: 57da30f405ba37a5d4844f32bb292271b81faee2
Gecko: a19e0434ea52
Version: 33.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Open_C 2.0

2.0 Environmental Variables:
Device: Open_C 2.0
Build ID: 20140625000201
Gaia: de77f794db22a45f9d575de2c6e266a30a50de3b
Gecko: 79712bd7b60d
Version: 32.0a2 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Buri 2.0

2.0 Environmental Variables:
Device: Buri 2.0
Build ID: 20140625000201
Gaia: de77f794db22a45f9d575de2c6e266a30a50de3b
Gecko: 79712bd7b60d
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Buri 1.4

1.4 Environmental Variables:
Device: Buri 1.4
Build ID: 20140625000201
Gaia: c9416de14acf9e94ab006619cd2418c768422fcb
Gecko: cddf88f78632
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Flame 1.4

1.4F Environmental Variables:
Device: Flame 1.4
Build ID: 20140625000201
Gaia: c9416de14acf9e94ab006619cd2418c768422fcb
Gecko: cddf88f78632
Version: 30.0 (1.4)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Open_C 1.4

1.4 Environmental Variables:
Device: Open_C 1.4
Build ID: 20140625000201
Gaia: c9416de14acf9e94ab006619cd2418c768422fcb
Gecko: cddf88f78632
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Open C 1.3:

1.3 Environmental Variables:
Device: Open_C 1.3
BuildID: 20140505052400
Gaia: Unknown Git commit; build date shown here.
Gecko:
Version: 28.0
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0


Buri 1.3

1.3 Environmental Variables:
Device: Buri 1.3
Build ID: 20140625024001
Gaia: 7a25ded52cf1164196098545be4fa7d5111fd526
Gecko: 8ef1dadd6278
Version: 28.0 (1.3)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.3: --- → affected
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
Flags: needinfo?(ktucker)
Whiteboard: [2.0-flame-test-run-2]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Could you please attach the provisioning document sent to the device please?, do you see the MMS APN in the MMS APN list in the settings app once the APN is installed through the WAP PUSH app? Are you sure the APN sent in the provisioning document is the right one? I mean if the APN is installed correctly and the APN is wrong the MMS might not be sent/received and this wouldn't be a WAP PUSH app issue.
Flags: needinfo?(dharris)
I do not know how to get the provisioning document off of the NowSMS app to attach. If you could please provide steps on how to attach this document I will be more than happy to get that information for you. As for your second question, the answer is yes. I am able to see the CHT_MMS setting in the phone under Settings App> SIM 1> Message settings. As for the information that was put into the provisioning document when I sent it, I am sure that the information that was provided in the test case correctly matches what was input into the OMA provisioning content in the NowSMS app.
Flags: needinfo?(dharris) → needinfo?(javsmo)
NI'ed the wrong person.
Flags: needinfo?(javsmo) → needinfo?(josea.olivera)
(In reply to dharris from comment #3)
> I do not know how to get the provisioning document off of the NowSMS app to
> attach. If you could please provide steps on how to attach this document I
> will be more than happy to get that information for you. 

Unfortunately I don't know anything about the NowSMS app. Sorry :(

> As for your second
> question, the answer is yes. I am able to see the CHT_MMS setting in the
> phone under Settings App> SIM 1> Message settings. As for the information
> that was put into the provisioning document when I sent it, I am sure that
> the information that was provided in the test case correctly matches what
> was input into the OMA provisioning content in the NowSMS app.

If you see the APN installed after being this installed through the WAP PUSH app and you cannot send/receive MMS messages it might mean the APN is wrong.

FYI there are test cases in the WAP PUSH app (at [1]) with provisioning documents sent by CHT, please have a look at them and check whether the APN you are sending is correct.

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/wappush/test/unit/parsed_doc_test.js#L67-L134
Flags: needinfo?(josea.olivera)
Why am I added to this thread?

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(dharris)
Whiteboard: [2.0-flame-test-run-2] → [2.0-flame-test-run-2][2.1-flame-test-run-1]
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(dharris)
After further investigation I was able to send and receive MMS messages using same T-Mobile SIM as Comment 1 with the following custom APN received through WAP push.

T-Mobile:
Connection Type: GPRS
Settings Name: T-Mobile_Custom
GPRS Access Point Name: fast.t-mobile.com
WAP Proxy IP Address : 216.155.165.050
WAP Proxy Port: 8080
Home Page URL: http://wap.voicestream.com
MMS Message Server: http://mms.msg.eng.t-mobile.com/mms/wapenc
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(dharris)
Looks like the test case needs to be updated to reflect the apn setting of our telecom, which in our case would be T-Mobile.
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(dharris)

Comment 9

7 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.