Closed Bug 1030447 Opened 6 years ago Closed 6 years ago

Copying URL bar adds moz-action:switchtab, to URL for sites open in other tabs

Categories

(Firefox :: Address Bar, defect)

32 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1024133

People

(Reporter: beta, Unassigned)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140624004001

Steps to reproduce:

Go to copy a URL from the address bar, entered some text to find the site in history, it appears to be loaded in another tab, did ctrl+a to select all and ctrl+c to copy.
It’s been happening for a few weeks, but uncertain when it first occurred re: version.

While searching for an existing bug I noticed https://bugzilla.mozilla.org/show_bug.cgi?id=556061 which was verified fixed in 2011-02-12.


Actual results:

Firefox put moz-action:switchtab,http://www.google.com/design/spec/components/buttons.html#buttons-usage onto the clipboard


Expected results:

http://www.google.com/design/spec/components/buttons.html#buttons-usage should have gone onto the clipboard
(In reply to John Drinkwater (:beta) from comment #0)
> User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101
> Firefox/32.0 (Beta/Release)
> Build ID: 20140624004001
> 
> Steps to reproduce:
> 
> Go to copy a URL from the address bar, entered some text to find the site in
> history, it appears to be loaded in another tab, did ctrl+a to select all
> and ctrl+c to copy.

I'm presuming you first arrow down to the relevant entry in the dropdown list before hitting ctrl+a ?

I can't seem to reproduce this on 31 beta or on 32... you're seeing this on 32? Can you reproduce it without add-ons enabled ?
Component: Untriaged → Location Bar
Flags: needinfo?(john)
Can reproduce on Aurora 32 (with extensions on) & Nightly 33 (with none).

I notice my report is incorrect, apologies: process is: new tab, type something, down arrow to entry, hold shift, press home, the URL now incorrectly includes the switchtab text
Flags: needinfo?(john)
I can reproduce on Linux, but not on OS X. Odd. I'll try to get a regression range.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to :Felipe Gomes from comment #5)
> Dupe of bug 1024133?

Yes.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(mak77)
Resolution: --- → DUPLICATE
Duplicate of bug: 1024133
You need to log in before you can comment on or make changes to this bug.