[Homescreen] Cookies are disabled for homescreen bookmark apps

RESOLVED DUPLICATE of bug 1021113

Status

RESOLVED DUPLICATE of bug 1021113
5 years ago
5 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected)

Details

Attachments

(1 attachment)

Created attachment 8446248 [details]
2014-06-25-16-41-47.png

1. launch browser
2. go to www.cnn.com
3. create a homescreen bookmark
4. tap home
5. tap the CNN bookmark

Expected: CNN mobile page
Actual: CNN mobile site requires cookies

Gaia      de77f794db22a45f9d575de2c6e266a30a50de3b
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/79712bd7b60d
BuildID   20140625000201
Version   32.0a2
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
Flame
blocking-b2g: --- → 2.0?
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
Blocks: 989848
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
This is unrelated to the vertical homescreen. More likely a gecko bug. Adding qawanted to check 1.4.
No longer blocks: 989848
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
Keywords: qawanted
I am fairly certain that this is another data point, but still a dupe of bug 1021113.

The problem is on the CNN side, it sets a cookie and redirects the user to this page: http://m.cnn.com/primary/Home?cookieFlag=COOKIE_SET

You can enter that page in a browser, and you will see the same problem. CNN is expecting anyone that visits that URL to have cookies.
Status: NEW → RESOLVED
blocking-b2g: 2.0? → ---
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 1021113
You need to log in before you can comment on or make changes to this bug.