Link Toolbar Improvements Tracking (site navigation bar)

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
17 years ago
2 years ago

People

(Reporter: choess, Assigned: chofmann)

Tracking

(Depends on: 6 bugs, {html4, meta})

Trunk
html4, meta
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [HTML4-12.3])

(Reporter)

Description

17 years ago
I'm filing a meta-bug to track the various bugs filed on the link toolbar.  The
cc list of interested parties is based on the autoshow bug...
(Reporter)

Comment 1

17 years ago
This should cover all the dependencies, add 'em if ya got 'em...
(Reporter)

Comment 2

17 years ago
qa->claudius
QA Contact: zach → claudius

Updated

17 years ago
No longer depends on: 102897

Updated

17 years ago
Depends on: 102897

Comment 3

17 years ago
Any reason why the default qa contact for UID can't be qa for UID bugs?

Comment 4

17 years ago
As this is a meta bug, moving to Tracking.
Component: User Interface Design → Tracking

Updated

17 years ago
Depends on: 103097

Comment 5

17 years ago
Adding dependency:

Bug 103062 - "Alternate Stylesheets should appear on link toolbar"
Depends on: 103062

Updated

17 years ago
Depends on: 103183

Comment 6

17 years ago
adding bug 103204: link toolbar does not work with frames
Depends on: 103204
(Reporter)

Updated

17 years ago
Depends on: 103223

Updated

17 years ago
No longer depends on: 103223

Comment 7

17 years ago
Please include dependency to good old bug #2800 to make this tracking bug an
easy access point to all bugzilla discussions about link UI implementations!

Comment 8

17 years ago
OK, made this bug depend on bug 2800 and bug 87428 (the two bugs for the 
original implementation).
Depends on: 2800, 87428
(Reporter)

Updated

17 years ago
Depends on: 103223
(Reporter)

Updated

17 years ago
Depends on: 103264
(Reporter)

Updated

17 years ago
Depends on: 103273

Updated

17 years ago
Depends on: 6782
(Reporter)

Updated

17 years ago
Depends on: 103034
(Reporter)

Updated

17 years ago
Depends on: 103417

Updated

17 years ago
Depends on: 103429

Updated

17 years ago
Depends on: 103428

Updated

17 years ago
Depends on: 103436

Updated

17 years ago
Depends on: 103456

Updated

17 years ago
Depends on: 103459
(Reporter)

Updated

17 years ago
Depends on: 103469

Updated

17 years ago
Depends on: 103470

Updated

17 years ago
No longer depends on: 6782

Updated

17 years ago
Depends on: 103474
removing myself from cc -- please don't cc me on meta bugs, thanks! :-)
(Reporter)

Updated

17 years ago
Depends on: 103571

Updated

17 years ago
Depends on: 103588

Updated

17 years ago
Depends on: 103604

Updated

17 years ago
No longer depends on: 103474, 103571, 103588, 103604

Comment 10

17 years ago
Removing self from CC, if you think I should know about it, CC me on the 
bug in question.
(Reporter)

Updated

17 years ago
Depends on: 103704
(Reporter)

Updated

17 years ago
Depends on: 103721
(Reporter)

Updated

17 years ago
No longer depends on: 103704

Updated

17 years ago
No longer depends on: 103721

Comment 11

17 years ago
ok. this time they're going back in!

Comment 12

17 years ago
OK, sorry for the spam, but I'm trying to put the deps back to the right value
and bugzilla/nav4 aren't playing nice. Trying in Mozilla.
Depends on: 103474, 103571, 103588, 103604, 103721
(Reporter)

Updated

17 years ago
Depends on: 103906

Updated

17 years ago
Depends on: 104074
These are the six bugs that I consider to be the most important in immediate
Links toolbar development, and I strongly encourage the Links toolbar community
to tackle them as Job 1, in the given order.

102992 - Link Toolbar should be converted to XBL
102990 - Site navigation toolbar should be inside content frame
102905 - Site navigation toolbar doesn't update when tabs are switched
102987 - Use more secure way of getting current document URL in links toolbar
102909 - No keyboard access to link toolbar
102912 - E-mail links in link toolbar are not marked
Gerv

Updated

17 years ago
Depends on: 104586

Updated

17 years ago
Depends on: 104618

Updated

17 years ago
Depends on: 105109

Updated

17 years ago
No longer depends on: 104618

Updated

17 years ago
Depends on: 104618
(Reporter)

Updated

17 years ago
Depends on: 107691
(Reporter)

Updated

17 years ago
Depends on: 109307

Updated

17 years ago
Depends on: 109467

Comment 14

17 years ago
I think this bug should become a component.  Tracking a huge number of bugs 
using dependencies only makes searching difficult, and especially when the 
feature used to have a different name.  cf -turbo, quick launch, and bug 75599.
Summary: Link Toolbar Improvements Tracking → Link Toolbar Improvements Tracking (site navigation bar)

Updated

17 years ago
Depends on: 110014

Updated

17 years ago
Depends on: 109180
I agree Jesse, 

Anything with more than say 20+ bugs for stuff like this maybe componentizing
them would be helpful for mozilla and querying in the long run.

Comment 16

17 years ago
Filed bug 111517, Add "site navigation bar" component.

Updated

17 years ago
Depends on: 119000

Updated

17 years ago
Depends on: 119087, 119088

Updated

17 years ago
Depends on: 119478
(Reporter)

Updated

17 years ago
Depends on: 119858

Updated

17 years ago
Depends on: 113100
(Reporter)

Updated

17 years ago
Depends on: 121816
(Reporter)

Updated

17 years ago
Depends on: 123188

Updated

17 years ago
Depends on: 110020

Updated

17 years ago
Depends on: 123379

Updated

17 years ago
Depends on: 127588
(Reporter)

Updated

17 years ago
Depends on: 127777
(Reporter)

Updated

17 years ago
Depends on: 128800

Updated

17 years ago
Depends on: 131184

Comment 17

17 years ago
Cleaning out duplicates.
Bug 15332 is added to replace bug 104324.
Depends on: 15322
No longer depends on: 102886, 102991, 103183, 103273, 103588, 103721, 104074, 104324, 107691, 128800, 131184

Comment 18

17 years ago
Make that bug 15322, not bug 15332.
Depends on: 102991
No longer depends on: 102911

Updated

17 years ago
Depends on: 135619

Updated

17 years ago
Depends on: 138496

Comment 19

17 years ago
bug 138496 is filed to back out the linktoolbar from the 1.0 branch. I hate
doing it but it seemed to be the consensus in discussion with drivers. If you
don't want it to happen, discuss it in the bug - or better yet, fix bug 102992.

Updated

17 years ago
Depends on: 140083

Updated

17 years ago
Depends on: 152845
Tracking bug -> nobody.

Gerv
Assignee: gerv → nobody
(Reporter)

Updated

17 years ago
Depends on: 155918
(Reporter)

Updated

17 years ago
Whiteboard: [HTML4-12.3]
(Reporter)

Comment 21

17 years ago
*** Bug 157896 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Depends on: 158227

Updated

16 years ago
Depends on: 173674

Comment 22

16 years ago
Here's a usability issue, albeit not a bug:

Things like "Author", "Search" and "Copyright" is placed under the dropdown "More", together with "Bookmarks" and "Other versions". I don't think they should be grouped like that, because if "Search" is used on *one* page on a site, it is likely to be used on *every* page on that site. Thus, the "More" button remains clickable all the time. But "Bookmarks" or "Other versions" may only be present on individual pages. But since the the "More" button is clickable all the time, the user won't get any hints when there is extra info available.

(Originally posted at <http://my.opera.com/forums/showthread.php?s=&postid=39991&t=8404#post39991>)
(Reporter)

Updated

16 years ago
Depends on: 112560
(Reporter)

Updated

16 years ago
Depends on: 205278
(Reporter)

Updated

16 years ago
Depends on: 207463

Updated

16 years ago
Depends on: 201979

Updated

15 years ago
Depends on: 128372

Updated

14 years ago
Depends on: 104360

Updated

14 years ago
Assignee: nobody → chofmann
QA Contact: claudius → chofmann

Updated

13 years ago
Depends on: 202958
Depends on: 320693

Comment 23

2 years ago
Marking all tracking bugs which haven't been updated since 2014 as INCOMPLETE.
If this bug is still relevant, please reopen it and move it into a bugzilla component related to the work
being tracked. The Core: Tracking component will no longer be used.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.