All users were logged out of Bugzilla on October 13th, 2018

[Sora][HOMO][ Bug 56788][Regional] Differentiation between MMS and SMS

RESOLVED WONTFIX

Status

P2
normal
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sms-most-wanted])

(Reporter)

Description

4 years ago
Firefox OS v1.3
 Mozilla build ID:20140422024003
 _______________________________________________________________________________
     A.- Overview Description (technical background, concise explanation of the bug):
     
 Each type of message: SMS and MMS shall be identified by a particular icon with the object of being able to differentiate between the types of messages.
    
     ________________________________________________________________________________
     B.- Steps to Reproduce (initial conditions, required resources, step by step instructions to reproduce):
     
 1) Receive a SMS & MMS
 * Check the notification 
 * Check the notification bar
 * Check the message app
 * Check the messages inside a chat
 
 2) Compose and send a SMS & MMS
 * Check the composition screen
 * Check the message app
 * Check the messages inside a chat
     ________________________________________________________________________________
     C.- Actual Result (current bad behaviour that is reported as a bug):
     
 1) Receive a SMS & MMS (with only text)
 * Check the notification > No diferences between SMS & MMS
 * Check the notification bar > No diferences between SMS & MMS
 * Check the message app > MMS are distinguished with a string in orange "MMS" [OK]
 * Check the messages inside a chat > No diferences between SMS & MMS
 
 2) Compose and send a SMS & MMS 
 * Check the composition screen > "Converting to SMS/MMS", size in Kb and "MMS" in orange [OK]
 * Check the message app > MMS are distinguished with a string in orange "MMS" [OK]  
 * Check the messages inside a chat > No diferences between SMS & MMS
     
     ________________________________________________________________________________
     D.- Expected Result (correct behaviour wished):
     
 Each kind of message must be differentiated with a different icon.    
     ________________________________________________________________________________
     E.- Additional information (possible causes suspected, hints to debug, related bugs):
     
     
     ________________________________________________________________________________
     F.- Tracking information (MSISDN, IMEI, other information useful for bug tracking. Required for UK):
     MSISDN: +34616091495
     IMEI: a) IMEI 864604020002857 #001 (42601)
     Other:
This is IMO useless information. The user does not need to know if a received message is SMS or MMS. If he really wants to know, he can longpress the message and then choose "show message report".

The only thing that matters is the current in-progress message, because a MMS costs more money than a SMS.

So I'd like to WONTFIX this bug.

But let's NI our UX master Jenny before :)
Flags: needinfo?(jelee)

Comment 2

4 years ago
Hi there ;) 

For received message, I don't see the need to indicate the difference between MMS & SMS every step of the way (notification, tray). Notification/tray has extremely little space, we're already showing message preview and sender name which is more important compared to message type. 
  
However, I agree it can helpful to show the info inside a chat. The reason why user wants to know message type is most likely concerning the fee incurred, by providing a *subtle visual hint* indicating which message is MMS, we give user a general idea of how many MMS has been received. Indicating SMS seems redundant to me though. For sent message, we can probably do the same just to indicate which are the MMSs.   

NI UI master Vicky to comment on this :)
Flags: needinfo?(jelee) → needinfo?(vpg)
(In reply to Jenny Lee from comment #2)
> Hi there ;) 
> 
> For received message, I don't see the need to indicate the difference
> between MMS & SMS every step of the way (notification, tray).
> Notification/tray has extremely little space, we're already showing message
> preview and sender name which is more important compared to message type. 
>   
> However, I agree it can helpful to show the info inside a chat. The reason
> why user wants to know message type is most likely concerning the fee
> incurred, by providing a *subtle visual hint* indicating which message is
> MMS, we give user a general idea of how many MMS has been received.
> Indicating SMS seems redundant to me though. For sent message, we can
> probably do the same just to indicate which are the MMSs.   
> 
> NI UI master Vicky to comment on this :)

I agree with you both and the visual designs made for this are based on previous specs. So, from the visual POV I have nothing to say. I just preffer no more infomation in the inbox screen, this is a visual improvement for me.

Cheers.
Flags: needinfo?(vpg)
I don't think this is part of Fang's work.

NI Fang so that she knows about this request from UX.
Flags: needinfo?(fshih)
Whiteboard: [sms-most-wanted]

Comment 5

4 years ago
Hi there, looking at the new thread view design, I don't think it's wise to add more information to message bubble as there's already quite a lot of info placed at the same spot. Let's WONTFIX this bug, thanks :D!
Flags: needinfo?(fshih)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.