[Stage] Intermittent device location failures

NEW
Unassigned

Status

Firefox OS
FindMyDevice
3 years ago
6 months ago

People

(Reporter: marcia, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [NPOTB])

Attachments

(2 attachments)

Created attachment 8446557 [details]
newfmd.txt

Flame, while running:

Gaia   c478c43229883cee2afd09c6edb42d29a46cc500
SourceStamp 8940337ccb5c
BuildID 20140625160200
Version 32.0a2
Base image: 122

STR:
1. Follow instructions on https://wiki.mozilla.org/User_Services/Try_FMD to setup device
2. Sign into FF account and Enable FMD
3. Log in to website with same account

Expected: It would locate the device
Actual: The spinner continues and the device is never located

Some other details

*Tried this 3 times, failed 2 times. Device was in exact same location, exact same build, signed in with same account.  One failure was last evening and one failure occurred this morning.

*Geolocation is on, I am connected to wifi and I am using an AT&T SIM that has good coverage.

*On the website side, I am using the latest Firefox beta.

*Tried signing in and out of device and website, etc. but it still did not find it. Cleared cache, restarted browser and tried again.

Logcat attached. Happy to provide more log info if people will point me to what they need.

Comment 1

3 years ago
Debugging tips, I wish I wasn't this complex...

remember that switching fxa on a device requires factory reset and stage pref push, otherwise, you will toil in pain.

If you know that it's not accounts issue: same acct on multiple phones, switching accts then try the following.

fmd traces in logcat, enable:
fxOS > Settings > Developer > Gaia debug traces. 

in the web app, open up console and paste what it says.

to confirm a-GPS is locating you properly:
1. launch GeoLocation app on phone, 
2. click 'start'
3. when you see print out to status, look at the lat/long/accuracy. eventually it should print your current location. may take a few minutes
I am not sure everyone knows about the factory reset - that definitely should be documented especially if a clean flash is not enough. And for sure I wasn't doing a factory reset, and at least one time it did work.

Also do we have to do a factory reset every time we change accounts on the device, or only initially?

The Geolocation app is only on the engineering build - we typically are testing with user builds on a daily basis since that is what we smoketest the daily builds on. I can confirm Geolocation by trying another app on the phone.
I reset the device, changed the prefs and this time it located my device, but ring, lost mode and erase didn't work.

Gaia   de77f794db22a45f9d575de2c6e266a30a50de3b
SourceStamp 79712bd7b60d
BuildID 20140625000201
Version 32.0a2

Comment 4

3 years ago
:marcia - have you signed into a different phone with that fx acct?  I still think it's a bug - but it might help.  

FWIW: I'm repro'ing your this bug - but I'll log a new one since it sounds like you're 1/2 way to resolved

Comment 5

3 years ago
I just repro'd comment #3 - able to located but ring/lost/erase didn't work. Actually, ring/lost/erase eventually worked but it took about 2-3 minutes before it occurred.  Here's my gaia trace:

<snip>
about 100 failed push registrations
</snip>
13777:I/GeckoDump( 2313): [findmydevice] command t, args [0]
13778:I/GeckoDump( 2313): [findmydevice] command t, args [0]
13947:I/GeckoDump( 2313): [findmydevice] command t, args [60]
14029:I/GeckoDump( 2313): [findmydevice] command r, args [30]
14209:I/GeckoDump( 2313): [findmydevice] command r, args [30]
14406:I/GeckoDump( 2313): [findmydevice] command l, args ["khkhkjh","1111"]
How did things look as of 06/27?
noming as blocker; should be since this is the #1 source of pain for QA at the moment.
blocking-b2g: --- → 2.0?

Updated

3 years ago
blocking-b2g: 2.0? → 2.0+
Whiteboard: [NPOTB]

Comment 8

3 years ago
I hear there is a fix for this, but I don't see a patch?  Perhaps I should be looking at a github repo?
Hey ggp, any chance you can look at this in the morning? This is the #1 QA blocker and doesn't seem to be actively worked on.
Flags: needinfo?(ggoncalves)
Seems like this bug is related on the server side:

https://github.com/mozilla-services/FindMyDevice/issues/172
Will do. Reading the scrollback yesterday, it looked like a client issue.
Flags: needinfo?(ggoncalves)
Created attachment 8450150 [details]
devicetesting.txt

This morning I have had no luck getting the device located. I tried both times around the middle of the hour to avoid the server restart which I believe is happening every 30 minutes.

This is before and after an OTA.
next time, it would be helpful to enable gaia tracing and geolocation debugging (from the developer menu)

Updated

3 years ago
Target Milestone: --- → 2.0 S6 (18july)

Updated

3 years ago
Assignee: nobody → ggoncalves
After discussing some of these issues with the geolocation team, we've found that we can't really rely on geolocation to work on Flame running 2.0, and that this configuration doesn't reflect what will actually go to market, because devices running 2.0 will feature an entirely different geolocation stack that doesn't use MLS and is thus entirely out of our control.

Erin will work on getting access to 2.0 builds that do represent what will be commercialized, and once she does, we should expect geolocation to work well on those builds. The sad part is that these are not nightly builds (we don't know much about their periodicity yet), so this may end up slowing down QA. 

Still, for the time being, we should not worry too much about geolocation-related bugs that happen on Flame running 2.0 (in particular, we don't want to block on those), but rather cross-check them against these other builds when they are available.

Updated

3 years ago
blocking-b2g: 2.0+ → ---

Updated

3 years ago
Target Milestone: 2.0 S6 (18july) → ---

Comment 15

3 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
Assignee: ggoncalves → nobody

Comment 16

3 years ago
removing this bug from the nom list as it has the [NPOTB] whiteboard
blocking-b2g: 2.1? → ---

Comment 17

6 months ago
Closing all intermittent test failures for Firefox OS (since we're not focusing on it anymore).

Please reopen if my search included your bug by mistake.
You need to log in before you can comment on or make changes to this bug.