user interface unresponsive while sync is active

RESOLVED DUPLICATE of bug 1210296

Status

()

Firefox
Sync
RESOLVED DUPLICATE of bug 1210296
4 years ago
10 months ago

People

(Reporter: Phil Pishioneri, Unassigned)

Tracking

31 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

Activating sync by adding a bookmark, modifying one, etc. 

I sync bookmarks, tabs, and history. Have approximately 13,000 bookmarks.


Actual results:

While sync is active (I have the icon on the menu bar so I can see the circular arrows spinning), the entire user interface is unresponsive to keyboard or mouse. During the sync the interface may become responsive again for a moment and it processes queued interactions, but it will not act normally again until sync is finished.


Expected results:

Interface should not hang. Did not happen under previous versions. I reinstalled version 29 and the problem went away. Problem returned when upgraded to version 30.x.

Tried with new, clean profile (no extensions), same behavior.

Only noticed on Mac OS X; Windows and Linux version 30 appear to act appropriately.
(Reporter)

Updated

4 years ago
Hardware: x86 → x86_64

Updated

4 years ago
QA Whiteboard: [bugday-20140630]
Component: Untriaged → Sync
(Reporter)

Comment 1

4 years ago
Problem still exists in release 31.0.
Version: 30 Branch → 31 Branch
I see no reason why this would be different with 30 versus 29, but I suspect this is a good dupe of Bug 1210296.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1210296
You need to log in before you can comment on or make changes to this bug.