If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Calendar] Week View: ui is not updating to reflect new locale

RESOLVED FIXED

Status

Firefox OS
Gaia::Calendar
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: millermedeiros, Assigned: millermedeiros)

Tracking

(Blocks: 1 bug)

unspecified
All
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.0 affected, b2g-v2.1 verified)

Details

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
Created attachment 8446597 [details]
week_view_toggle_l10n.png

steps to reproduce:

 1. open calendar app.
 2. go to week view.
 3. open settings app and switch language.
 4. go back to calendar app.

expected: all strings on the week view should be on the proper locale.

actual: week header (Thu 26, Fri 27...) and event times (12 AM, 1 AM...) are not localized.
(Assignee)

Updated

3 years ago
Assignee: nobody → mmedeiros
blocking-b2g: --- → 2.0?
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
Target Milestone: --- → 2.0 S5 (4july)
triage: assuming this is corrected by restarting the app, we generally don't block on locale changes since this is an infrequent use case. We should fix this but won't block or uplift.
blocking-b2g: 2.0? → ---
Target Milestone: 2.0 S5 (4july) → 2.0 S6 (18july)
blocking-b2g: --- → backlog
Target Milestone: 2.0 S6 (18july) → ---
(Assignee)

Updated

3 years ago
See Also: → bug 1047213
(Assignee)

Updated

3 years ago
Depends on: 1023662
(Assignee)

Comment 2

3 years ago
I'm closing this since it is resolved on master. (by Bug 1023662)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.1: affected → fixed
Resolution: --- → FIXED

Comment 3

3 years ago
This issue has been verified successfully on Flame2.1
Verify video:"verify_1030804.mp4

Flame2.1 Bulid:
Gaia-Rev        db2e84860f5a7cc334464618c6ea9e92ff82e9dd
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/211eae88f119
Build-ID        20141126001202
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141126.033519
FW-Date         Wed Nov 26 03:35:30 EST 2014
Bootloader      L1TC00011880
status-b2g-v2.1: fixed → verified

Comment 4

3 years ago
Created attachment 8529566 [details]
Verified video: verified_1030804.MP4
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.