Closed Bug 1030821 Opened 6 years ago Closed 6 years ago

[Camera] mozCamera.zoom is busted

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S5 (4july)
blocking-b2g 2.0+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: justindarc, Assigned: aosmond)

References

Details

(Keywords: regression)

Attachments

(2 files, 2 obsolete files)

The `mozCamera.zoom` attribute is busted in the latest build on master (v2.1).

Last working build:
Gaia      1bcd355855626640b2532f2ccb1f814711f7a6ad
Gecko     https://hg.mozilla.org/mozilla-central/rev/da1dbcff9493
BuildID   20140625160202
Version   33.0a1

First broken build:
Gaia      87a7746568ac5708e828026160c0732ba252300f
Gecko     https://hg.mozilla.org/mozilla-central/rev/c43be7e4ec49
BuildID   20140626040205
Version   33.0a1

Also, flashing latest Gaia with the Gecko of the last working build (20140625160202) works. The issue is likely somewhere within the Camera Control API.
hg 190732:7a84bd4bb3da appears to be the root cause. Working on isolating specific part of change that caused problem and will resolve.
Status: NEW → ASSIGNED
Assignee: nobody → aosmond
Attached patch Fix zoom, v1 (obsolete) — Splinter Review
The type for the recording hint was wrong, as the Set in SetConfigurationInternal would auto cast to an integer type instead of complaining about the lack of a bool equivalent.
Attachment #8447352 - Flags: review?(mhabicher)
Attached patch Fix zoom, v2 (obsolete) — Splinter Review
Umm. Yeah, no idea what happened there. HG is unhappy :).
Attachment #8447363 - Flags: review?(mhabicher)
Attachment #8447352 - Attachment is obsolete: true
Attachment #8447352 - Flags: review?(mhabicher)
Comment on attachment 8447363 [details] [diff] [review]
Fix zoom, v2

Review of attachment 8447363 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good--thanks for fixing this.
Attachment #8447363 - Flags: review?(mhabicher) → review+
The two test failures from the try appear to be unrelated to this change.
Keywords: checkin-needed
try fixing the broken builds (I thought linux64_gecko would have captured this build class but not so much, sigh): https://tbpl.mozilla.org/?tree=Try&rev=7d9bd83bcff6
Attachment #8447363 - Attachment is obsolete: true
Attachment #8447982 - Flags: review+
try succeeded for broken builds
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e94590e830ff
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Based on the new bug 1033411 which is filed against an aurora/v2.0 build, this patch needs to be backported to that tree as well.
Blocks: 1025197
blocking-b2g: --- → 2.0?
Duplicate of this bug: 1033411
Will this break on v1.4 once bug 1025197 is uplifted there as well?
status-b2g-v1.4: --- → ?
Ryan: Re v1.4, yes; this patch should go anywhere the one in bug 1025197 goes.
I'm testing the new version of the v1.4 patch for bug 1025197 now, to make sure it doesn't re-break that build. It should be ready for landing soon.
Talking to Mike in IRC, he's going to include the fix for this in the v1.4 patch in bug 1025197.
Target Milestone: --- → 2.0 S5 (4july)
Duplicate of this bug: 1033037
blocking-b2g: 2.0? → 2.0+
Keywords: regression
Hi Justin,
    Could you provide the detailed reproduce steps for me to verify this bug?

Thank you!
Flags: needinfo?(jdarcangelo)
(In reply to Shally from comment #21)
> Hi Justin,
>     Could you provide the detailed reproduce steps for me to verify this bug?
> 
> Thank you!

Sure.

1. Open "Camera"
2. Ensure mode toggle switch is set for "Photo" mode
3. Use pinch-to-zoom gesture to zoom the viewfinder
4. Observe that the viewfinder zooms in/out
5. Additionally, take a picture and observe that the saved picture also has the zoom applied to it
Flags: needinfo?(jdarcangelo)
This issue has been successfully verified on Flame v2.1&2.0.
See attachment: verified_v2.1.mp4.
Reproduce rate: 0/5.

Flame v2.0 build
Gaia-Rev        856863962362030174bae4e03d59c3ebbc182473
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/2d0860bd0225
Build-ID        20141210000202
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141210.034839
FW-Date         Wed Dec 10 03:48:50 EST 2014
Bootloader      L1TC00011880

FLame v2.1 build:
Gaia-Rev        c226db212db4d824c09617cd6dc407b2d4258d9b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/cf8bebfa4703
Build-ID        20141210001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141210.035300
FW-Date         Wed Dec 10 03:53:11 EST 2014
Bootloader      L1TC00011880
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.