Use the Contacts API for erasing contacts

RESOLVED WONTFIX

Status

Firefox OS
FindMyDevice
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: ggp, Assigned: ggp)

Tracking

unspecified
2.0 S5 (4july)

Firefox Tracking Flags

(blocking-b2g:2.0+)

Details

(Assignee)

Description

4 years ago
We used to rely on factoryReset erasing contacts, but it looks like that doesn't work on Flame: https://bugzilla.mozilla.org/show_bug.cgi?id=1028943#c3. We should do it properly and use ContactManager.clear(), instead.

https://developer.mozilla.org/en-US/docs/Web/API/ContactManager.clear

Updated

4 years ago
Target Milestone: --- → 2.0 S5 (4july)
This feels non-trivial. We'll get an assignee in the next ~24 hours.
blocking-b2g: --- → 2.0?
Hey Doug - can we rely on the factory reset method here? I think we rely on it for SMS deletion already.
Flags: needinfo?(dougt)
I'll + this because we need this for the FMD use case, but we need a separate bug on file for factory reset itself not working correctly.
blocking-b2g: 2.0? → 2.0+
(In reply to Jason Smith [:jsmith] from comment #3)
> I'll + this because we need this for the FMD use case, but we need a
> separate bug on file for factory reset itself not working correctly.

Yeah, very good point, Jason. If we knew factory reset worked reliably cross-device, we could close out this bug and bug 1032565 as well. Maybe that's the better approach?
Actually, bug 1032565 has been backlogged for 2.0. Maybe we should do the same thing here?
(In reply to Jared Hirsch [:_6a68] [@6a68] from comment #5)
> Actually, bug 1032565 has been backlogged for 2.0. Maybe we should do the
> same thing here?

bug 1032565 was backlogged because it was speculative whether it was a problem that an end user could hit, where as this bug was confirmed to be a problem from QA testing.
(In reply to Jared Hirsch [:_6a68] [@6a68] from comment #4)
> (In reply to Jason Smith [:jsmith] from comment #3)
> > I'll + this because we need this for the FMD use case, but we need a
> > separate bug on file for factory reset itself not working correctly.
> 
> Yeah, very good point, Jason. If we knew factory reset worked reliably
> cross-device, we could close out this bug and bug 1032565 as well. Maybe
> that's the better approach?

I think that would be better approach - let's fix the root cause in factory reset itself. If factory reset isn't doing wiping data correctly, then that's a blocker we need to fix.
(Assignee)

Comment 8

4 years ago
:dhylands and :gerard-majax just confirmed over IRC that factory reset is indeed guaranteed to erase both contacts and sms messages, so we don't need this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(dougt)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.