[B2G][Contacts][SMS]Able to open contact view twice through app chaining

RESOLVED INVALID

Status

Firefox OS
Gaia::Contacts
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Ross Kuhlman (rkuhlman@qanalydocs.com), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2.0-daily-testing])

Attachments

(1 attachment)

Created attachment 8446693 [details]
ContactsToMessagesToContacts.txt

User can sideload the messaging app from contact details page. From the message thread, the user can sideload the contact details page. This results in a scenario when the user can back out of contact details into messaging app and back into contact details again

Repro Steps:
1) Update a Flame to BuildID: 20140626000202
2) Launch contacts app
3) View the details page of a contact with a valid phone number
4) Tap the 'send message' button
5) Send a message to the number. (Message thread should now be displayed)
6) Tap the contact name at the top of the screen
7) Select 'view contact details'


Actual:
Contact details page is loaded. User can back out of details into messaging and back out of messaging into details again

Expected:
Apps cannot be double chained. Performing steps 6-7 has similar function to pressing 'X' button in upper left corner.

v2.0 Environmental Variables:
Device: Flame v2.0 MOZ
BuildID: 20140626000202
Gaia: 6a1373340b40fcfe901336bc9e80676e5f2ba979
Gecko: 82ef9bf64d87
Version: 32.0a2
Firmware Version: v122

Notes:

Repro frequency: 100%
See attached: logcat
adding qawanted to determine if issue occurs on 1.4 or Master
QA Whiteboard: [QAnalyst-Triage?]
Keywords: qawanted
Whiteboard: [2.0-daily-testing]
(Reporter)

Updated

4 years ago
Flags: needinfo?(jmitchell)
QA-Wanted to get a video of this first, then kick it back to me before doing branch checks
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
That behaviour has been introduced on purpose.
Hi Francisco - 

I just wanted to clarify - you are saying we should close this as invalid / by design

correct?
Flags: needinfo?(francisco)
Hi Joshua,

yes, sorry for being more clear on my previous explanation, but basically I meant that.

Cheers,
F.
Flags: needinfo?(francisco)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.