User Login at screaming-penguin.com crashes browser

VERIFIED DUPLICATE of bug 102936

Status

()

Core
HTML: Form Submission
--
critical
VERIFIED DUPLICATE of bug 102936
17 years ago
17 years ago

People

(Reporter: blockcipher, Assigned: Eric Vaughan)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.4+) Gecko/20011003
BuildID:    2001100303

Every time I have tried to log in to screaming-penguin.com to check my news, my
browser crashes.  This is the second nightly build that this has occured in.  I
only use builds recommended by Mozillazine as good builds.  Figured that would
be useful to see when this occured since I don't remember the build id of the
nightly I tried yesterday.

Reproducible: Always
Steps to Reproduce:
1. Go to http://screaming-penguin.com
2. Try to log in using a valid account.  (perhaps an invalid one too?)

Actual Results:  Browser crashes.  Forgot to get crash info.

Expected Results:  Mozilla should have submitted my login information and
proceeded to load my custom news page.

I've tried this with a few other sites that require logins, but those have
worked without any problems.  I'll try to get crash data today.
(Reporter)

Comment 1

17 years ago
Error message:

The instuction at "0x6084cb4b" referenced memory at "0x00000000".  The memory
could not be "read".

Hope this helps.
Reporter: Can you try it with a talkback enabled build ?
After talback submitted the crash run (install-Dir)\components\talkback.exe and
poste the Talkback ID here.

Thanks
Severity: normal → critical
Keywords: crash

Comment 3

17 years ago
This happens with my 2001-10-02-08-trunk Solaris SPARC builds (Xlib+GTK+
toolkits), too... ;-(

Stack trace:
-- snip --
Reading libimgpng.so
Opening file 2153837.s failed
Document http://screaming-penguin.com/ loaded successfully
Reading libpippki.so
xxlib_find_handle: 'xxlib-default' entry 16ba40
WEBSHELL+ = 5
xxlib_find_handle: 'xxlib-default' entry 16ba40
xxlib_find_handle: 'xxlib-default' entry 16ba40
###!!! ASSERTION: Attempt to decrement focus controller's suppression when no
suppression active!
: 'PR_FALSE', file
../../../../../../src/2001-10-02-08-trunk/mozilla/dom/src/base/nsFocusController.cpp,
line 416
###!!! Break: at file
../../../../../../src/2001-10-02-08-trunk/mozilla/dom/src/base/nsFocusController.cpp,
line 416
WEBSHELL- = 4
###!!! ASSERTION: You can't dereference a NULL nsCOMPtr with operator->().:
'mRawPtr != 0', file ../../../../dist/include/xpcom/nsCOMPtr.h, line 664
###!!! Break: at file ../../../../dist/include/xpcom/nsCOMPtr.h, line 664
t@1 (l@1) signal SEGV (no mapping at the fault address) in
nsHttpChannel::ProcessResponse at line 485 in file "nsHttpChannel.cpp"
  485                   rv =
mCacheEntry->GetTransport(getter_AddRefs(mCacheTransport));
(/opt/SUNWspro/bin/../WS6U2/bin/sparcv9/dbx) where
current thread: t@1
=>[1] nsHttpChannel::ProcessResponse(this = ???) (optimized), at 0xfdd68494
(line ~485) in "nsHttpChannel.cpp"
  [2] nsHttpChannel::OnStartRequest(this = ???, request = ???, ctxt = ???)
(optimized), at 0xfdd6e6f8 (line ~2262) in "nsHttpChannel.cpp"
  [3] nsOnStartRequestEvent::HandleEvent(this = ???) (optimized), at 0xfdcf9d8c
(line ~131) in "nsRequestObserverProxy.cpp"
  [4] nsARequestObserverEvent::HandlePLEvent(plev = ???) (optimized), at
0xfdcf8428 (line ~79) in "nsRequestObserverProxy.cpp"
  [5] PL_HandleEvent(self = ???) (optimized), at 0xff0dc770 (line ~590) in
"plevent.c"
  [6] PL_ProcessPendingEvents(self = ???) (optimized), at 0xff0dc5b8 (line ~520)
in "plevent.c"
  [7] nsEventQueueImpl::ProcessPendingEvents(this = ???) (optimized), at
0xff0de8a4 (line ~389) in "nsEventQueue.cpp"
  [8] HandleQueueXtProc(ptr = ???, source_fd = ???, id = ???) (optimized), at
0xfdbbc60c (line ~449) in "nsAppShell.cpp"
  [9] DoOtherSources(0x163e20, 0xfdb92000, 0x1, 0x564, 0xfdc0bf94, 0xfdc07f6c),
at 0xfdb5ac60
  [10] XtAppNextEvent(0x163e20, 0x0, 0x1, 0x0, 0xffbef02c, 0x5), at 0xfdb5aa14
  [11] nsAppShell::Run(this = ???) (optimized), at 0xfdbbc738 (line ~493) in
"nsAppShell.cpp"
  [12] nsAppShellService::Run(this = ???) (optimized), at 0xfe12a348 (line ~456)
in "nsAppShellService.cpp"
  [13] main1(argc = ???, argv = ???, nativeApp = ???) (optimized), at 0x17030
(line ~1312) in "nsAppRunner.cpp"
  [14] main(argc = ???, argv = ???) (optimized), at 0x17a68 (line ~1633) in
"nsAppRunner.cpp"
-- snip --
OS: Windows NT → All
Hardware: PC → All

Comment 4

17 years ago
->
Assignee: rods → evaughan
(Reporter)

Comment 5

17 years ago
Here's the talback ID: TB36281309Z

Sorry it took so long, but I didn't want to do it at work.  Nice to see the bug
is consistent.  :-)
Roland's stack trace sez this is bug 102936.  It should be fixed in Oct 4 or
newer builds.

*** This bug has been marked as a duplicate of 102936 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.