Closed Bug 1031012 Opened 7 years ago Closed 7 years ago

[B2G][Camera]Self-timer cannot be canceled

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 verified, b2g-v2.1 verified)

RESOLVED FIXED
2.0 S5 (4july)
blocking-b2g 2.0+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: JMercado, Assigned: justindarc)

References

()

Details

(Keywords: regression, Whiteboard: [2.0-flame-test-run-2])

Attachments

(4 files)

Description:
Taking a picture with the self-timer enabled cannot be stopped by pressing the shutter again.  Switching between picture and video will stop the countdown.  This issue occurs with all three durations of self-timer available.


Repro Steps:
1) Update a Flame to 20140625000201
2) Open the camera app
3) Enable self-timer
4) Press the shutter button and then again to attempt to stop after the coutndown begins


Actual:
The user cannot stop the countdown by pressing the shutter button again.


Expected:
the user can stop the countdown.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140625000201
Gaia: de77f794db22a45f9d575de2c6e266a30a50de3b
Gecko: 79712bd7b60d
Version: 32.0a2 (2.0)
Firmware Version: v122

User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/13277/
See attached: logcat, video
This issue DOES occur on Flame 2.1, Buri 2.1, Open C 2.1, Buri 2.0, and Open C 2.0.

Flame 2.1
2.1 Environmental Variables:
Device: Flame Master
Build ID: 20140625040202
Gaia: 57da30f405ba37a5d4844f32bb292271b81faee2
Gecko: a19e0434ea52
Version: 33.0a1 (Master)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Buri 2.1
2.1 Environmental Variables:
Device: Buri Master
Build ID: 20140625040202
Gaia: 57da30f405ba37a5d4844f32bb292271b81faee2
Gecko: a19e0434ea52
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Open_C 2.1
2.1 Environmental Variables:
Device: Open_C Master
Build ID: 20140625040202
Gaia: 57da30f405ba37a5d4844f32bb292271b81faee2
Gecko: a19e0434ea52
Version: 33.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Buri 2.0
2.0 Environmental Variables:
Device: Buri 2.0
Build ID: 20140625000201
Gaia: de77f794db22a45f9d575de2c6e266a30a50de3b
Gecko: 79712bd7b60d
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0 

Open_C 2.0
2.0 Environmental Variables:
Device: Open_C 2.0
Build ID: 20140625000201
Gaia: de77f794db22a45f9d575de2c6e266a30a50de3b
Gecko: 79712bd7b60d
Version: 32.0a2 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0 

Actual results: The timer cannot be stopped by pressing the shutter again.

This issue does NOT occur on Flame 1.4.

Flame 1.4
1.4F Environmental Variables:
Device: Flame 1.4
Build ID: 20140625000201
Gaia: c9416de14acf9e94ab006619cd2418c768422fcb
Gecko: cddf88f78632
Version: 30.0 (1.4)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Actual results: The timer can be stopped by pressing the shutter again.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Nominating this 2.0? since this a regression in camera. This feature was working correctly on 1.4.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+]
Wilson, can you please take a look once you are back in office on Monday.

Thanks
Hema
Assignee: nobody → wilsonpage
blocking-b2g: 2.0? → 2.0+
Assignee: wilsonpage → jdarcangelo
Attached file pull-request (master)
Diego: You know what to do :-)

Tif: As part of fixing this bug, we are now hiding the controls at the bottom of the screen while the self-timer countdown is in-progress. Tapping anywhere on-screen cancels the countdown (as it always did). I wanted to get your input since we are no longer displaying the controls during the countdown. One thought I had from a usability standpoint was to maybe show some on-screen text during the countdown (like we already do when you change a setting). Something like "Tap anywhere to cancel" maybe. However, if you think that it is a must that we show the bottom controls, I'd like to make a suggestion that maybe we change the icon on the shutter button to something else like an "X" or something (to indicate cancel) and maybe even possibly remove the preview thumbnail and picture/video toggle buttons (leaving only the shutter button). Personally, I think its more aesthetically pleasing to fade ALL controls out (we already were fading out the HUD buttons at the top), but I'd also be ok with showing a bit of text if we need to as well.
Attachment #8447416 - Flags: ui-review?(tshakespeare)
Attachment #8447416 - Flags: review?(dmarcos)
From the interaction point of view looks very nice. You touch wherever in the screen. You cannot miss it :). I would for sure keep the thumbnail and the mode switch hidden. Replacing the capture button with a "X" might be good a idea to make the cancel accordance more perceptible. Anyways the cancel operation on the whole has a high discoverability even without an "X". If you start the timer by mistake the first thing you will almost certainly do is touching the screen to see what happens. No much else you can do on a phone these days :)

I'm going to see the code now.
Almost there. I made some suggestions on github to reuse patterns we have in other views to hide/show them.
(In reply to Diego Marcos [:dmarcos] from comment #7)
> Almost there. I made some suggestions on github to reuse patterns we have in
> other views to hide/show them.

Diego: I had to update the PR to *not* toggle the shutter button (only thumbnail and mode switch are now hidden). Therefore, we can't rely on View.show()/hide().
Comment on attachment 8447416 [details] [review]
pull-request (master)

Asked justindarc to keep the shutter button visible during countdown and he updated the patch. Looks good to me!

NI'ing Amy - Amy do you want to change the shutter button to look different as Diego suggests or leave it the way it is?
Attachment #8447416 - Flags: ui-review?(tshakespeare) → ui-review+
Flags: needinfo?(amlee)
Attachment #8447416 - Flags: review?(dmarcos) → review+
Target Milestone: --- → 2.0 S5 (4july)
Landed on master:

https://github.com/mozilla-b2g/gaia/commit/de3bdeabc0823e4d4c25f178363b8cbea8c56a86
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Needs a branch patch for v2.0 uplift.
Flags: needinfo?(jdarcangelo)
(In reply to Tiffanie Shakespeare from comment #9)
> Comment on attachment 8447416 [details] [review]
> pull-request (master)
> 
> Asked justindarc to keep the shutter button visible during countdown and he
> updated the patch. Looks good to me!
> 
> NI'ing Amy - Amy do you want to change the shutter button to look different
> as Diego suggests or leave it the way it is?

Hi, 

I'd leave the shutter button the way it is. I think any sort of cancel indicator at that large of size would be too jarring. Thanks
Flags: needinfo?(amlee)
If it's not fixed on master, please reopen the bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Amy Lee [:amylee] from comment #12)
> (In reply to Tiffanie Shakespeare from comment #9)
> > Comment on attachment 8447416 [details] [review]
> > pull-request (master)
> > 
> > Asked justindarc to keep the shutter button visible during countdown and he
> > updated the patch. Looks good to me!
> > 
> > NI'ing Amy - Amy do you want to change the shutter button to look different
> > as Diego suggests or leave it the way it is?
> 
> Hi, 
> 
> I'd leave the shutter button the way it is. I think any sort of cancel
> indicator at that large of size would be too jarring. Thanks

I'm not sure why you changed the status of v2.1 from fixed -> affected? It sounds as though you were simply providing after-the-fact feedback that what we did with the shutter button in this patch is acceptable, correct?
Flags: needinfo?(amlee)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #13)
> If it's not fixed on master, please reopen the bug.

Ryan: This is fixed on master. I spoke with Amy on IRC and it seems that the flag was inadvertently flipped back to affected. I will get you a patch for v2.0 now.
Flags: needinfo?(jdarcangelo)
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Attached file pull-request (v2.0)
Carrying over R+ for v2.0 uplift.
Attachment #8450217 - Flags: review+
Attached video VIDEO0052.mp4
This issue has been successfully verified on Flame 2.0:
Gaia-Rev        99e4594c66aa3738d58b0cb44bd885a87a063b6e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/f91abc6127d9
Build-ID        20141125000201
Version         32.0
Device-Name     flame
FW-Release      4.4.2


This issue has been successfully verified on Flame 2.1:
Gaia-Rev        1bdd49770e2cb7a7321e6202c9bf036ab5d8f200
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/db893274d9a6
Build-ID        20141125001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
Flags: needinfo?(amlee)
You need to log in before you can comment on or make changes to this bug.