If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

Other Applications
ChatZilla
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Thomas Bopp, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: on-branch, URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080110

The password is not send to our irc server. After receiving the nick of the user
the server responds with password required and nothings happens. Right after
typing the uri chatzilla asks for the password though.

Reproducible: Always
Steps to Reproduce:
1.use the uri given above
2.see what happens
3.the password is "mozilla"

Actual Results:  not possible to login the server

Expected Results:  login works ok, automatically join a channel
(Assignee)

Comment 1

16 years ago
In addition, isnick urls are not actually implemented.  Feel free to file
another bug.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Updated

16 years ago
Summary: url does not work, because passwort submitting does not work → url does not work, because password submitting does not work
(Assignee)

Updated

16 years ago
Depends on: 103386
(Assignee)

Comment 2

16 years ago
bug 102377 will track the password fix, this one can be for isnick implementation.
Summary: url does not work, because password submitting does not work → implement isnick urls
(Assignee)

Updated

16 years ago
Whiteboard: on-branch
(Assignee)

Comment 3

16 years ago
The chatzilla 0.8.5 branch has landed, if you believe this bug is not actually
fixed, and you are sure you are running chatzilla 0.8.5-rc1, please reopen the
bug for further consideration.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 4

14 years ago
Currently, isnick works.
But in the last draft of IETF
(http://www.ietf.org/internet-drafts/draft-butcher-irc-url-04.txt), isnick has
been replaced by isuser (which allows for exemple values such nick!username...)

And isuser doesn't seem to be implemented in Chatzilla.
(Do you think I should fill another bug ?)
(Assignee)

Comment 5

14 years ago
ChatZilla isn't going to change until that document moves past draft status, and
the way things are going, that's not going to happen for a while.
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.