Closed Bug 1031186 Opened 6 years ago Closed 5 years ago

set family name on font entries more eagerly

Categories

(Core :: Graphics: Text, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1031187

People

(Reporter: heycam, Unassigned)

References

Details

Attachments

(1 file)

In bug 1028497 we will need to be able to create gfxProxyFontEntry objects (and resolve them to real font entries) that haven't been added to a gfx{Mixed,}FontFamily.  Currently mFontFamily on the entry is set only once the entry is added to the font family.  For the font entry objects created outside the user font set to go in the user font cache, they need to have their mFamilyName set.  This patch sets it as soon as we create a gfxProxyFontEntry and also once we resolve the gfxProxyFontEntry to an actual font entry.  There are some situations where we don't have the font family name to store on the font entry -- such as in gfxMacFontFamily::FindStyleVariations -- so I've made gfx{Mixed,}FontFamily::AddFontEntry set the family name if it hasn't been set yet, and if it has been set already, assert that it's the same as the name on the family object.
Weird dupe of bug 1031187 that I only just now got bugmail for?
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1031187
You need to log in before you can comment on or make changes to this bug.