Closed Bug 1031292 Opened 6 years ago Closed 6 years ago

[geolocation] Map doesn't always center to result

Categories

(Participation Infrastructure :: Phonebook, defect)

2014-07.3
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: giorgos, Assigned: wbowling)

Details

Steps to reproduce:
 - Go to /user/edit
 - Type 'athens' in search box. Select with mouse first result. Map moves, fields update
 - Type 'surinam' in search box. Select with mouse first result. Map doesn't move, fields update.

Expected:
 - Map should move
Flags: needinfo?(wbowling)
Uh oh... This is a bigger problem. Roads can be entered into the search and get false positive responses.

The first result for "Surinam" is this road
http://www.openstreetmap.org/way/230282749

Similarly, I can make the same bug occur if i type in the name of any road "i-40" or "A21" or "Autobahn" all result in the same bug. I'll see if there's some way to exclude roads in our results.
Flags: needinfo?(wbowling)
Bingo. We can simply filter out data that isn't a country, province, or city with the mapbox ID.

https://www.mapbox.com/developers/api/geocoding/
(In reply to Wray Bowling [:wbowling] from comment #2)
> Bingo. We can simply filter out data that isn't a country, province, or city
> with the mapbox ID.

Nice! Do you want to work on this bug, Wray?
PR: https://github.com/mozilla/mozillians/pull/1017
Assignee: nobody → wbowling
Status: NEW → ASSIGNED
Commit pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/4ac3dcc6151cc41fb2090cd9d101e73ebcc14149
[fix bug 1031292] Limit geocoding results to city, region and country.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Version: other → next
I cannot reproduce anymore the problem described in comment #0 on stage. Marking this one verified/fixed.

Thanks :wbowling!
Status: RESOLVED → VERIFIED
Version: next → 2014-07.3
You need to log in before you can comment on or make changes to this bug.