Status

SeaMonkey
Bookmarks & History
--
critical
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Bill Nicholls, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I just lost months of bookmarks because there is no way that I can find,
automated or manual, to move bookmarks from an older version of Mozilla (0.9.2)
to current (0.9.4).

**I have no idea how many hours or days it will take to recover, but I am furious!**

Installing 0.9.4 over 0.9.2, with overwrite, yielded an unbreakable loop loading
Mozilla that required a CAD to kill the loop, which had locked the system
maiking multiple copies of Mozilla. This sucks.

Installing 0.9.4 fresh in a different directory  and moving the profile did not
move the bookmarks. Moving the bookmark file manually and then reloading Mozilla
caused the 0.9.4 version to OVERWRITE the desired bookmarks with a new copy of
the empty bookmark file despite my having stored the new file in its place. 

This cost me my only  current copy of the bookmarks, which I use to write my
columns for Byte. I shall try and recover with an older copy. 

Bookmarks are *critical* intellectual property, the result of weeks or months 
of web browsing and work. Under *no* circumstances should they be deleted or
overwritten. At most, new bookmarks should cause old bookmarks to be saved as a
a backup file, as deep as necessary. Recovery of an older bookmark file should
proceed on a stack basis, swithcing temporarily to the older stack and allowing
the user to review before making that version current. 

There really ought to be some way to combine stacks from multiple
versions/sources as well. Bookmark management may need to become a separate tool
that the user can initiate from the folder or tool menu.

THE QUICK FIX: Never overwrite/replace/delete without explicit permission from
the user. Let the user select which file to be active.

Comment 1

17 years ago
I copy bookmarks.html between multiple profiled (even across multiple OSes) all
of the time with no problem. This should be done with the browser closed. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs which haven't changed since 2001.12.31.

set your search string in mail to "EmperorLondoMollari" to filter out these
messages.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.