Have http://ronpiovesan.com/ removed from planet

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: rcampbell, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
I saw this roll through the feed:

http://ronpiovesan.com/2014/06/27/financial-services-find-relate-and-engage-with-the-best-prospects-on-linkedin-and-hearsay-social/

Other than a cursory connection with "social" this has nothing to do with the web or Mozilla.

Notify the owner, take it down, etc.
Thanks for the heads-up, purging.

Committed revision 129846.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Duplicate of this bug: 1033416
You need to log in before you can comment on or make changes to this bug.