If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can't add items to saved cart at CDW site

VERIFIED INVALID

Status

()

Core
Networking: Cookies
VERIFIED INVALID
16 years ago
15 years ago

People

(Reporter: Scott I. Remick, Assigned: Stephen P. Morse)

Tracking

({qawanted})

Trunk
x86
Windows 2000
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Unable to use QuickCart to add additional items to a previously-saved cart at CDW's site.  The page refreshes, but the cart hasn't been changed.

To recreate:

Go to CDW.  Find an item, add it to your cart.  While looking at the cart, click on "Save this cart" (link in upper-right, just above "Continue to checkout" button).  Name it anything. You should now be on the "Manage Carts" page.  Click on the name of the cart you just created.  In the QuickCart field, enter in another CDW item# (for example, 282624).  Click on the (+) button to add it to the cart.  Page will refresh, but the item you just added isn't there.

First noticed in 0.9.4, just tested with 20011004 nightly.
Reporter: Is this still occuring for you in a more recent build?
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-talkback.zip
(as always, be sure to delete your Mozilla directory before installing the new one)

-> Cookies, for lack of a better idea
Assignee: asa → morse
Component: Browser-General → Cookies
QA Contact: doronr → tever
(Assignee)

Comment 2

16 years ago
tever, can you confirm this?
(Reporter)

Comment 3

16 years ago
Stillbroke as of 20011028
Scott: You may wish to try a fresh profile. You can manage/create profiles with
"mozilla.exe -profilemanager".
(Reporter)

Comment 5

16 years ago
Alex,

I always prune out the entire profile folder (incl registry.dat), and the entire
\bin folder, every time I upgrade builds.  Done so since M3. :)
Ok, marking NEW.

-> QAWanted for testcase, please
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
(Assignee)

Comment 7

16 years ago
Rewriting summary so that it is not all on one line.  This makes it possible to 
read it using a non-wrapping browser.

---------------------------------------------

Unable to use QuickCart to add additional items to a previously-saved cart at 
CDW's site.  The page refreshes, but the cart hasn't been changed.

To recreate:

Go to CDW.  Find an item, add it to your cart.  While looking at the cart, click 
on "Save this cart" (link in upper-right, just above "Continue to checkout" 
button).  Name it anything. You should now be on the "Manage Carts" page.  Click 
on the name of the cart you just created.  In the QuickCart field, enter in 
another CDW item# (for example, 282624).  Click on the (+) button to add it to 
the cart.  Page will refresh, but the item you just added isn't there.

First noticed in 0.9.4, just tested with 20011004 nightly.
(Assignee)

Comment 8

16 years ago
OK, I just tested this out and it behaves exactly as reporter claims.  Then I 
tried it on IE and it again behaves exactly as reporter claims.  I even tried it 
on 4.x and it behaved worse -- when I click on the cart name I get to a screen 
which has the CDW banner on top but nothing else.

Looks like this site has problems.  Not a browser problem.  Not even an 
evanglism problem since it doesn't work on other browsers.  So closing out as 
invalid.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 9

15 years ago
verified INVALID
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.