Some dialog titles can not be seen on OS X

RESOLVED WONTFIX

Status

()

Core
XUL
RESOLVED WONTFIX
17 years ago
16 years ago

People

(Reporter: TucsonTester2, Assigned: jag (Peter Annema))

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build ID: 20011002

If you choose the "Insert Characters and Symbols" window in OS X you will see
that the "Insert Character" title is cut off.

Reproducible: Always

Steps to Reproduce:
1.Open composer
2.Click on Insert -> Character and Symbols

Actual Results:
You will notice that the "Insert Character" title is cut off.  Most likely this
is because of the buttons in the title bar.  In all other OS's these buttons are
not present.

Expected Results:
The window should show the entire title as it does on every other os.

Updated

17 years ago
Blocks: 102998

Comment 1

17 years ago
Confirmed using Fizzilla/2001091313 (0.9.4). The window's narrow width precludes the entire 
"Insert Character" window dialog from being visible. Instead, "Insert Char..." is shown. The 
window should probably be made wider so the whole title is visible.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

17 years ago
changed the title to better reflect this bug. Also here are a couple more
windows that have this problem:

Horizontal Line Properties
Anchor Properties
Summary: "Insert Character" title can not be seen on OS X → Some dialog titles can not be seen on OS X
this is a toolkit issue, i would venture. the window/dialog auto-sizing needs to
take the title width into consideration. (how did syd end up with this bug?)
Assignee: syd → hyatt
Component: Editor: Composer → XP Toolkit/Widgets
QA Contact: sujay → jrgm

Comment 4

17 years ago
I don't believe the window title bar should participate in the auto-sizing code.
 You'd have to add a lot of logic to do that, and make it support concepts of
minwidth, preferred width, and max width, in order to put caps on obscenely long
titles, etc.  It's especially dicey when you consider the different Window
managers on Linux (that can support wrapping title text vs. cropped text, etc.
etc.).

Status: NEW → ASSIGNED
Target Milestone: --- → Future

Updated

17 years ago
No longer blocks: 102998

Updated

17 years ago
Blocks: 102998

Comment 5

17 years ago
I'm going to agree with hyatt on this one.  Removing status as blocker of
102998.  Unless someone strenuously objects this can probably be closed as WONTFIX.
No longer blocks: 102998

Comment 6

16 years ago
--> default owner
Assignee: hyatt → jaggernaut
Status: ASSIGNED → NEW
Target Milestone: Future → ---

Comment 7

16 years ago
So ... wontfix (given no objections since February).
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.