Add missing COMPUTED_STYLE_PROP declaration for 'box-decoration-break'

RESOLVED FIXED in Firefox 32

Status

()

P3
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mats, Assigned: mats)

Tracking

Trunk
mozilla33
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox30 unaffected, firefox31 unaffected, firefox32+ fixed, firefox33 fixed)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

4 years ago
Created attachment 8447340 [details] [diff] [review]
Add missing COMPUTED_STYLE_PROP declaration for 'box-decoration-break'

This was part of the patches for bug 613659 but apparently got lost
while a rebased the patches... :-(
Attachment #8447340 - Flags: review?(roc)
(Assignee)

Updated

4 years ago
Blocks: 1006326
How did this pass tests?
(Assignee)

Comment 4

4 years ago
(In reply to David Baron [:dbaron] (UTC-7) (needinfo? for questions) from comment #3)
> How did this pass tests?

The style system tests derived from property_database.js are
not run for properties that are disabled (they failed when
I enabled it).  The reftests that we do run with the pref
forced to 'true' only use simple CSS rules which apparently
don't need this thing to work.

Fwiw, I did do a full Try run with the pref enabled on an
earlier patch set that passed, but not on the final set
after the rebase.
I don't pretend to have any idea how this could be the case, but either this or bug 1028460 somehow broke /tests/dom/asmjscache/test/test_cachingBasic.html ("asm.js compilation is available") on Android 2.2 Armv6 Opt, https://tbpl.mozilla.org/php/getParsedLog.php?id=42694025&tree=Mozilla-Inbound

Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/c8ca361c8fea
(Assignee)

Comment 7

4 years ago
I think it's unlikely that it's this bug that caused the failure
so I pushed it again:
https://hg.mozilla.org/integration/mozilla-inbound/rev/dcbd6f52128c
https://hg.mozilla.org/mozilla-central/rev/dcbd6f52128c
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
(Assignee)

Comment 9

4 years ago
Comment on attachment 8447340 [details] [diff] [review]
Add missing COMPUTED_STYLE_PROP declaration for 'box-decoration-break'

Approval Request Comment
[Feature/regressing bug #]: bug 613659
[User impact if declined]: box-decoration-break will not work as intended
[Describe test coverage new/current, TBPL]: on m-c since 2014-06-29
[Risks and why]: zero risk
[String/UUID change made/needed]: none
Attachment #8447340 - Flags: approval-mozilla-aurora?
status-firefox30: --- → unaffected
status-firefox31: --- → unaffected
status-firefox32: --- → affected
status-firefox33: --- → fixed
tracking-firefox32: --- → +
Comment on attachment 8447340 [details] [diff] [review]
Add missing COMPUTED_STYLE_PROP declaration for 'box-decoration-break'

Aurora+
Attachment #8447340 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.