Closed Bug 1031503 Opened 6 years ago Closed 6 years ago

Homescreen does not show app icons

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1023796

People

(Reporter: tkundu, Unassigned)

Details

(Whiteboard: [caf priority: p1][CR 686636][systemsfe])

STR:
1. Open any app eg camera and start recording for a min
2. Go back to  Homescreen
3. None of app icon are visible on homescreen
4. Also sometimes icons are visible but homescreen becomes very sluggish.

Only option left is either to reboot the device or start stop b2g

It is seen in FFOS 2.0 . I think that you will be able to reproduce it very easily in Flame device running 2.0.

If you cannot reproduce it then we can provide SPS profiler trace and any logs if you need.
blocking-b2g: --- → 2.0?
Flags: needinfo?(msreckovic)
No-Jun, can you see it locally?
Flags: needinfo?(npark)
Not able to reproduce it on my Flame, latest 2.0 build. What device have you used?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?]
Whiteboard: [systemsfe]
Whiteboard: [systemsfe]
We are not able throttle down on our reference phone now, because of bug 1008050.
Depends on: 1008050
I meant throttle down to 256MB.
Whiteboard: [CR 686636]
Actually this looks like bug 1023796. Can you confirm Tapas?
Flags: needinfo?(tkundu)
(In reply to Johan Lorenzo [:jlorenzo] from comment #4)
> We are not able throttle down on our reference phone now, because of bug
> 1008050.

There's ways devs to get around this, so there isn't a hard dependency here. We need to work offline however to see if we can workaround that bug.
Blocks: 1015336
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?] → [VH-FL-blocking-][VH-FC-blocking+]
No longer depends on: 1008050
Whiteboard: [CR 686636] → [CR 686636][systemsfe]
(In reply to Johan Lorenzo [:jlorenzo] from comment #6)
> Actually this looks like bug 1023796. Can you confirm Tapas?

Probably is for the homescreen not showing. The homescreen being slow however is a different problem & probably should filed separately.
blocking-b2g: 2.0? → 2.0+
Depends on: 1023796
(In reply to Milan Sreckovic [:milan] from comment #1)
> No-Jun, can you see it locally?

I tried it on both flame and buri with the latest 2.0 branch, but it did not reproduce.  The version I used was:

Gaia      91958625774ebe6c425adf322b09f1edf906578d                         │
│ Gecko     https://hg.mozilla.org/mozilla-central/rev/9290d7995f98          │
│ BuildID   20140627040205                                                   │
│ Version   33.0a1                              

There was a bit of lag on flame device when reverting to homescreen, but it was about half a second.  It felt a bit faster on buri.  (yes, on buri device homescreen lag was not visible)
Flags: needinfo?(npark)
(In reply to Johan Lorenzo [:jlorenzo] from comment #6)
> Actually this looks like bug 1023796. Can you confirm Tapas?

I'm pretty sure this is a dup of that bug.  From the logging, the issue reproduces right after an app gets OOMed.

The step #4 from the original STR can be filed as a separate bug if needed.
Status: NEW → RESOLVED
blocking-b2g: 2.0+ → ---
Closed: 6 years ago
Resolution: --- → DUPLICATE
Whiteboard: [CR 686636][systemsfe] → [systemsfe]
Duplicate of bug: 1023796
Whiteboard: [systemsfe] → [CR 686636][systemsfe]
Whiteboard: [CR 686636][systemsfe] → [caf priority: p1][CR 686636][systemsfe]
The dupe here has the CAF meta bug tagged, so I'm removing this bug from the blocking list.
No longer blocks: CAF-v2.0-FC-metabug, 1015336
No longer depends on: 1023796
(In reply to Michael Vines [:m1] [:evilmachines] from comment #10)

> The step #4 from the original STR can be filed as a separate bug if needed.

Homescreen is using lots of memory and getting killed frequently 

https://bugzilla.mozilla.org/show_bug.cgi?id=1029902
Flags: needinfo?(tkundu)
Yes, we have some ideas as to where the extra memory is going; tracked in bug 1029902 and bug 1030608.
Flags: needinfo?(msreckovic)
You need to log in before you can comment on or make changes to this bug.