Status

()

RESOLVED DUPLICATE of bug 1031326
4 years ago
4 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

({regression})

31 Branch
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(firefox30 unaffected, firefox31 affected, firefox32 affected, firefox33 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8447410 [details]
screenshot

Build identifier:
https://hg.mozilla.org/releases/mozilla-beta/rev/a04918ac3197
Mozilla/5.0 (X11; Linux i686; rv:31.0) Gecko/20100101 Firefox/31.0 ID:20140626181429

This problem happens on a certain existing profile.

Steps To Reproduce:
1. Open about:support

Actual Results:
No data is displayed

TypeError: "Cu" is read-only resetProfile.js:7
1403902513094	Browser.Experiments.Experiments	ERROR	Experiments #0::_loadFromCache caught error: TypeError: data.set is not a function Log.jsm:760
A promise chain failed to handle a rejection.

Date: Sat Jun 28 2014 05:55:13 GMT+0900 (JST)
Full Message: TypeError: data.set is not a function Experiments.jsm:1450


Regression window(beta)
Good:
https://hg.mozilla.org/releases/mozilla-beta/rev/e8422257d229
Mozilla/5.0 (X11; Linux i686; rv:31.0) Gecko/20100101 Firefox/31.0 ID:20140625111004
Bad:
https://hg.mozilla.org/releases/mozilla-beta/rev/0c0706e210c3
Mozilla/5.0 (X11; Linux i686; rv:31.0) Gecko/20100101 Firefox/31.0 ID:20140626114343
Pushlog:
http://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=e8422257d229&tochange=0c0706e210c3
(Reporter)

Comment 1

4 years ago
Regression window(m-c)
Good:
https://hg.mozilla.org/mozilla-central/rev/bd03647cca20
Mozilla/5.0 (X11; Linux i686; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140626051608
Bad:
https://hg.mozilla.org/mozilla-central/rev/4c9d8c885791
Mozilla/5.0 (X11; Linux i686; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140626063407
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bd03647cca20&tochange=4c9d8c885791


Regression window(fx)
Good:
https://hg.mozilla.org/integration/fx-team/rev/549e5f2e49d0
Mozilla/5.0 (X11; Linux i686; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140625121405
Bad:
https://hg.mozilla.org/integration/fx-team/rev/5563efd9704c
Mozilla/5.0 (X11; Linux i686; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140625122006
Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=549e5f2e49d0&tochange=5563efd9704c

Suspect:
ea786f80e0d0	Benjamin Smedberg — Bug 1017806 - Record and report on optional branches of experiments, so that each experiment doesn't have to re-invent data collection. r=gfritzsche
Blocks: 1017806
(Reporter)

Comment 2

4 years ago
And other people also reported.
http://forums.mozillazine.org/viewtopic.php?f=23&t=2848313

Comment 3

4 years ago
Does anything show up in the browser console?

Comment 4

4 years ago
Oh nevermind.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1031326
(Reporter)

Updated

4 years ago
tracking-firefox31: ? → ---
tracking-firefox32: ? → ---
tracking-firefox33: ? → ---
Duplicate of this bug: 1031680
Duplicate of this bug: 1032112
You need to log in before you can comment on or make changes to this bug.