If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[1.4 => 2.0] Homescreen card is displayed in cards view after an OTA

RESOLVED DUPLICATE of bug 1027768

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED DUPLICATE of bug 1027768
3 years ago
3 years ago

People

(Reporter: jlorenzo, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.4 unaffected, b2g-v2.0 affected)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

Created attachment 8447413 [details]
Homescreen card view - Screenshot

Steps to reproduce
1. Flash your device to the latest 1.4 nightly build.
1bis. (Workaround) Change the channel to aurora with that script https://github.com/nhirata/B2G-flash-tool/blob/new_channels/change_channel.sh
2. Connect to a Wi-Fi network
3. Update via OTA
4. Once update is complete, go through the FTE
5. Long press home button
6. Flick right to see the leftmost card.

Actual result
A dark "homescreen" card is present. This appears to be the entry of the homecreen in 1.4. Tapping it leads you to a white page. See attached screenshot for details.
Same kind of issue as bug 1027768.
blocking-b2g: --- → 2.0?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
See Also: → bug 1027768
Appears that the patch for bug 1027768, should probably fix this as well. Going to mark as a dupe as the fix is contained within that bug.

Johan - It appears that it was just uplifted today, so could you verify that you no longer see this either on the latest master, or tomorrows nightly build? Thanks!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jlorenzo)
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 1027768

Updated

3 years ago
blocking-b2g: 2.0? → 2.0+

Updated

3 years ago
No longer blocks: 1015336
Keywords: qawanted
I don't think we need QA Wanted here - pretty sure this is definitely a dupe. We can verify that patch post landing though to confirm it.
That was a dupe!
blocking-b2g: 2.0+ → ---
Flags: needinfo?(jlorenzo)
You need to log in before you can comment on or make changes to this bug.