[Flame Nightly v2.1] [Keyboard] - Keyboard turns on uppercase after every letter typed.

RESOLVED DUPLICATE of bug 1036075

Status

Firefox OS
Gaia::Keyboard
RESOLVED DUPLICATE of bug 1036075
4 years ago
3 years ago

People

(Reporter: rdaub, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected)

Details

(Whiteboard: [SUMO-b2g])

(Reporter)

Description

4 years ago
ENVIRONMENT:
Device: Flame
Version: 2.1.0.0-prerelease
Build ID: 20140627040205

STEPS TO REPRODUCE:
1. Write SMS messages using the shift key to mark uppercase for the first letter of some words.

EXPECTED RESULTS:
After tapping on the shift key, the following letter should be uppercase, and after that go back to lowercase - unless the shift key is tapped twice for CAPS LOCK.

ACTUAL RESULTS:
1. I tap the shift key so that the first letter of the word is uppercase. 
2. After typing on the letter, the shift key remains active. 
3. I tap on the shift key to deactivate it so that the next letter is lower case.
4. I tap on the next letter.
5. The shift key activates itself again.
6. I tap on the shift key to deactivate it so that the next letter is lower case.
7. I tap on the next letter.
8. The shift key activates itself again.
9. If I keep typing, "THE SHIFT KEY REMAINS ACTIVE AND ALL LETTERS ARE UPPERCASE".

This behavior remains until I send the text. After that, the shift key goes back to working as expected and remains turned off if I manually turn it off.

I have not been able to find the exact steps to make the keyboard/SMS app go into this bugged state. However, it happens multiple times a day.

The general steps is writing an SMS, then tapping in the middle of the draft to edit the text, tap on the shift key, add words. I encounter this bug multiple times in the day when typing long messages (150+ characters).

Please let me know if there is any information I could provide to help with the investigation and troubleshooting of this issue.

Thanks,
- Ralph
QA Wanted to see if someone else can confirm.
Keywords: qawanted
(Reporter)

Comment 2

4 years ago
I am also experiencing this issue on version 2.0 nightly on the Flame device. 

It usually happens after typing around 150-200 characters on the SMS application, while moving the cursor around, and changing between upper/lower case a few times. At least on my device, it reproduces the majority of the time under this scenario.

Thanks,
- Ralph
QA Contact: mclemmons
(In reply to Jason Smith [:jsmith] from comment #1)
> QA Wanted to see if someone else can confirm.

Unable to reproduce the issue following the STR from Comment 0. However, was able to reproduce behavior with below STR:

1) Update a Flame to 20140708160204
2) Tap Messages App and New Message (pencil icon) 
3) Enter a recipient number in To: field and tap in Message field
4) Enter letter, tap once on shift key
5) Tap any string of letters (more than one)

Actual:
All letters are uppercase.

Expected:
Only first letter of string is upper case with remainder being lower case.

Repro frequency 6/6, 100%

Environmental Variables:
Device: Flame Master
Build ID: 20140708160204
Gaia: 740faa5d0060fb218b407cf224330654ddf833a5
Gecko: d35c1bf0f084
Version: 33.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted
Looks like bug 1036075, please help verify this won't occur after we fix bug 1036075.
Thanks.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1036075
(Reporter)

Comment 5

3 years ago
Hi Rudy,

I'm not sure if this is the same issue, since I encounter this bug even when I don't tap on a "word suggestion".

Having said that, I will keep testing for this issue once a patch has been submitted to bug 1036075 - hopefully it will also resolve this bug.

Thanks!! =)
- Ralph
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
You need to log in before you can comment on or make changes to this bug.